Bug 802830 - Replace incorrect uses of "Component Outline"
Replace incorrect uses of "Component Outline"
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Tzu-Mainn Chen
wes hayutin
:
: 805575 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 11:22 EDT by Angus Thomas
Modified: 2012-06-04 11:26 EDT (History)
10 users (show)

See Also:
Fixed In Version: v0.8.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss1 (213.43 KB, image/png)
2012-03-23 05:52 EDT, Rehana
no flags Details
ss2 (195.95 KB, image/png)
2012-03-23 05:52 EDT, Rehana
no flags Details
ss3 (198.42 KB, image/png)
2012-03-23 05:53 EDT, Rehana
no flags Details
ss4 (212.00 KB, image/png)
2012-03-23 05:53 EDT, Rehana
no flags Details
ss5 (223.68 KB, image/png)
2012-03-23 05:54 EDT, Rehana
no flags Details
ss6 (223.10 KB, image/png)
2012-03-23 05:54 EDT, Rehana
no flags Details
ss7 (220.69 KB, image/png)
2012-03-23 07:03 EDT, Rehana
no flags Details

  None (edit)
Description Angus Thomas 2012-03-13 11:22:32 EDT
Description of problem:

There are several points in the UI at which the term "Component Outline" is used incorrectly. Instead, "Image" should be used.

1. At "/conductor/pool_families" there is a green button labelled "New Component Outline". this should read "New Image"
2.  At "/conductor/pool_families" there are two sub-tabs, aligned to right, reading "Clouds" and "Component Outlines". The seceond of these should read "Images"
3. When viewing the details of an image (e.g. conductor/images/f86d43d4-6d1d-11e1-ae39-52540076a508), the button labelled "New Blueprint from Outline" should read "New Blueprint from Image"
4. When viewing the details of a cloud (e.g. /conductor/pool_families/1) there is a "Component Outlines sub-tab which should be labelled "Images"
5.  Within that sub-tab there is a "New Component Outline" button which should read "New Image"
6. The 'deletion' confirmation notice: "1 Component Outline Deleted", should refer to an Image, rather than to a "Component Outline"

As far as possible, this fixes should be applied by switching to another string from the dictionary with another, minimising the number of new strings which need to be translated.
Comment 1 Angus Thomas 2012-03-13 11:45:57 EDT
Also, when uploading the XML for a component outline (e.g. at /conductor/images/new?environment=1) the heading on that view should read "New Image" rather than "New Component Outline"
Comment 3 Tzu-Mainn Chen 2012-03-16 13:40:58 EDT
Pushed to 1.0-product:

commit 3ab5bce69b5931d60e4509dfecf9872d5453a002
BZ 802830 updated image tab tag for consistency

commit f804225b0cc9327f5e772435ae56d2df38b40b29
BZ 802830 removed unnecessary overrides that mistakenly replaced 'image' with 'component outline'
Comment 5 Rehana 2012-03-23 05:51:38 EDT
Observed that in couple of place its still refers to old name (component outline instead of image)

PFA the attachments 

repo used:

http://download.lab.bos.redhat.com/rel-eng/CloudForms/1.0/2012-03-22.3/

version:
rpm -qa | grep aeolus
aeolus-configure-2.5.2-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.8.3-1.el6.noarch
aeolus-conductor-0.8.3-1.el6.noarch
aeolus-conductor-doc-0.8.3-1.el6.noarch
aeolus-all-0.8.3-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 6 Rehana 2012-03-23 05:52:11 EDT
Created attachment 572218 [details]
ss1
Comment 7 Rehana 2012-03-23 05:52:36 EDT
Created attachment 572219 [details]
ss2
Comment 8 Rehana 2012-03-23 05:53:06 EDT
Created attachment 572220 [details]
ss3
Comment 9 Rehana 2012-03-23 05:53:45 EDT
Created attachment 572221 [details]
ss4
Comment 10 Rehana 2012-03-23 05:54:23 EDT
Created attachment 572227 [details]
ss5
Comment 11 Rehana 2012-03-23 05:54:58 EDT
Created attachment 572228 [details]
ss6
Comment 12 Rehana 2012-03-23 07:03:17 EDT
Created attachment 572243 [details]
ss7
Comment 13 Hugh Brock 2012-03-23 10:53:17 EDT
*** Bug 805575 has been marked as a duplicate of this bug. ***
Comment 14 Angus Thomas 2012-03-23 12:05:35 EDT
There are several instances here which are valid bugs, in that the name that is used ought to be changed

On ss1, all four occurrences should be switched to "image"
On ss2 , ss3 and ss4, no change is required. Those are correct references to component outlines.
On ss5, the occurrence should be switched to "image"
On ss6, all the occurences should be switched to "image"
On ss7, the occurrence should be switched to "image"
Comment 15 Tzu-Mainn Chen 2012-03-23 15:02:58 EDT
Patch created for these remaining cases:

http://post-office.corp.redhat.com/mailman/private/deltacloud-internal/2012-March/msg00103.html
Comment 16 Tzu-Mainn Chen 2012-03-26 10:57:35 EDT
Patch pushed to 1.0-product:

commit dcd63d5cd8ba6b3cba3a6363d1649e24cbf90cd8
BZ 802830 remove remaining overrides that mistakenly turn 'images' into 'component outlines'
Comment 17 errata-xmlrpc 2012-05-15 18:53:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.