Bug 802836 - Setting TMPDIR to path with length >74 cause hang of system utils [NEEDINFO]
Setting TMPDIR to path with length >74 cause hang of system utils
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-terminal (Show other bugs)
5.8
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Zeeshan Ali
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 11:27 EDT by temp356
Modified: 2016-09-19 21:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:17:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (temp356)


Attachments (Terms of Use)
Demostration of steps shown above. (542 bytes, text/plain)
2012-03-13 11:27 EDT, temp356
no flags Details

  None (edit)
Description temp356 2012-03-13 11:27:49 EDT
Created attachment 569702 [details]
Demostration of steps shown above.

Description of problem:
Commands such as "gnome-terminal --version" hang if length of fullpath to "$TMPDIR/orbit-<username>/bonobo-activation-register.lock" file greater than 121 

So, if aggragated length of $TMPDIR greater than 74 characters running of any system util cause hang.

Version-Release number of selected component (if applicable):


How reproducible:
> mkdir /tmp/folder_with_length_of_75_characters_or_more_....
> export TMPDIR=/tmp/folder_with_length_of_75_characters_or_more_....
> gnome-terminal --version
                             <<<<<< Hang. Press Ctrl-C to interrupt execution
> mkdir /tmp/folder_with_length_of_74_characters_or_less_....
> export TMPDIR=/tmp/folder_with_length_of_74_characters_or_less_....
> gnome-terminal --version
Gnome gnome-terminal 2.16.0  <<<<<< Expected result.
>

Steps to Reproduce:
1. Create folder <F> with length of 75 or more characters in fullpath
2. Set environment variable TMPDIR to point it: export TMPDIR=<F>
3. Run any system utility (e.g. "gnome-terminal --version")
  
Actual results:
Hang of system utility

Expected results:
Version of GUI environment is shown.

Additional info:
Limit shown above is created by lengh to following file
/path/to/orbit-<username>/bonobo-activation-register.lock
which is greater than 121 character in length to produce hang.
Comment 1 Roman Rakus 2012-03-16 06:22:30 EDT
How is this related to bash?
Comment 2 temp356 2012-04-01 04:05:48 EDT
I'm not experienced in Linux. So, after I faced the problem during work within shell, I submitted it on bash with hope that more experienced people reassign it on proper component.
It's not hard to reproduce, so, from my side it was important to narrow the scope and inform about steps leading to the issue.
I have different OS at home and can't spend additional time on investigation at work where issue was found. So, if you can, please, help to identify proper people for investigation or component to handle the issue further.
If this bugtracker is for expirience users only then sorry for disturbance (I haven't spent enough time to analyze tracker rools).
Comment 3 Roman Rakus 2012-04-02 08:15:54 EDT
Seems to be problem in gnome-terminal or something else in gnome.
Comment 4 RHEL Product and Program Management 2014-03-07 08:42:33 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 5 RHEL Product and Program Management 2014-06-02 09:17:12 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.