Bug 802857 - [RFE] Add statisitcs to the output of the migrate-ds command
[RFE] Add statisitcs to the output of the migrate-ds command
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Kosek
IDM QE LIST
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 12:22 EDT by Dmitri Pal
Modified: 2015-01-16 08:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-16 08:20:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-03-13 12:22:57 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/2495

The ipa migrate-ds performs migration without any output about the following information: 
 * How many entries are loaded so far
 * How many entries were not loaded due to errors
 * How much time did it take

I suggest we add a parameter, for example --stats=<number> where number denotes number of entries after which to report the statistics. For example --stats=1000 will output statistics every 1000 entries. The output might look like something like this:
{{{
Chunk, Entries, Time, Success, Failure
1, 1000, 5.34, 934, 66
2, 1000, 5.03, 891, 109
3, 389, 2.71, 380, 9
}}}

The output can be easily then put into the Calc and analyzed. We would be able to see: the process of load (that it is doing something), whether the the load slows down, whether it is successful and so on. Such stats will be very valuable during pilot and product evaluation when admin assesses what it would take to migrate to IPA.
Comment 2 Martin Kosek 2015-01-16 08:20:12 EST
Thanks for the report. Adding continuous migration status to the "ipa migrate-ds" command is not practical, as IPA commands return after they are completed (i.e. migration finishes).

However, Bug 904119 added continuous logging to /var/log/httpd/error_log, where one can track the progress of migration. If this is not sufficient, please file RFE for improving this log file.

Note You need to log in before you can comment on or make changes to this bug.