Bug 802868 - NoClassDefFoundError when starting portal on rhel6, openjdk1.6
NoClassDefFoundError when starting portal on rhel6, openjdk1.6
Status: CLOSED NOTABUG
Product: JBoss Enterprise Portal Platform 5
Classification: JBoss
Component: Portal (Show other bugs)
5.2.1.ER01
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Default User
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 12:52 EDT by mgottval
Modified: 2014-09-14 20:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 13:55:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mgottval 2012-03-13 12:52:18 EDT
Description of problem:
NoClassDefFoundError when starting portal on rhel6, openjdk1.6 :


Exception in thread "main" java.lang.NoClassDefFoundError: org/jboss/bootstrap/BaseServerConfig
	at org.jboss.bootstrap.AbstractServerImpl.doInit(AbstractServerImpl.java:190)
	at org.jboss.bootstrap.AbstractServerImpl.init(AbstractServerImpl.java:173)
	at org.jboss.bootstrap.AbstractServerImpl.init(AbstractServerImpl.java:143)
	at org.jboss.Main.boot(Main.java:218)
	at org.jboss.Main$1.run(Main.java:556)
	at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.ClassNotFoundException: org.jboss.bootstrap.BaseServerConfig
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
Comment 1 prabhat jha 2012-03-13 13:55:28 EDT
It was test enviornment issue. Not really a bug.

Note You need to log in before you can comment on or make changes to this bug.