Bug 802882 - Rpmdiff failure(s) for build rubygem-cloudfiles-1.4.17-2.el6
Rpmdiff failure(s) for build rubygem-cloudfiles-1.4.17-2.el6
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: rubygem-cloudfiles (Show other bugs)
1.0.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Steve Linabery
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 12:53 EDT by John Eckersberg
Modified: 2012-05-15 15:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 15:33:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Steve Linabery 2012-03-15 22:11:15 EDT
This change is ok because the patches are being applied. These lines in the spec:
/usr/bin/patch -s -p0 -b --suffix --fuzz=0 test/cloudfiles_authentication_test.rb %{PATCH0}
/usr/bin/patch -s -p0 -b --suffix --fuzz=0 test/cloudfiles_connection_test.rb %{PATCH1}
/usr/bin/patch -s -p0 -b --suffix --fuzz=0 test/cloudfiles_storage_object_test.rb %{PATCH2}

result in this output in the build.log:
+ /usr/bin/patch -s -p0 -b --suffix --fuzz=0 test/cloudfiles_authentication_test.rb /builddir/build/SOURCES/disable_test_bad_hostname.patch
+ /usr/bin/patch -s -p0 -b --suffix --fuzz=0 test/cloudfiles_connection_test.rb /builddir/build/SOURCES/disable_faulty_connection_tests.patch
patch unexpectedly ends in middle of line
+ /usr/bin/patch -s -p0 -b --suffix --fuzz=0 test/cloudfiles_storage_object_test.rb /builddir/build/SOURCES/disable_storage_object_test.patch
patch unexpectedly ends in middle of line
Comment 3 Dave Johnson 2012-03-30 10:49:42 EDT
Steve,

Are these lines in comment 1 expected...
      ...patch unexpectedly ends in middle of line

They make me nervous and just want to double check before marking this as verified.
Comment 4 Steve Linabery 2012-03-30 11:09:55 EDT
I just mocked it locally and installed the resulting rpm, and the patches are being correctly applied despite the warning. I believe it's ok to proceed.
Comment 5 wes hayutin 2012-03-30 14:57:52 EDT
assigning to rehana
Comment 6 wes hayutin 2012-04-03 09:53:23 EDT
This change is ok because the patches are being applied. These lines in the spec:
/usr/bin/patch -s -p0 -b --suffix --fuzz=0 test/cloudfiles_authentication_test.rb %{PATCH0}
/usr/bin/patch -s -p0 -b --suffix --fuzz=0 test/cloudfiles_connection_test.rb %{PATCH1}
/usr/bin/patch -s -p0 -b --suffix --fuzz=0 test/cloudfiles_storage_object_test.rb %{PATCH2}

result in this output in the build.log:
+ /usr/bin/patch -s -p0 -b --suffix --fuzz=0 test/cloudfiles_authentication_test.rb /builddir/build/SOURCES/disable_test_bad_hostname.patch
+ /usr/bin/patch -s -p0 -b --suffix --fuzz=0 test/cloudfiles_connection_test.rb /builddir/build/SOURCES/disable_faulty_connection_tests.patch
patch unexpectedly ends in middle of line
+ /usr/bin/patch -s -p0 -b --suffix --fuzz=0 test/cloudfiles_storage_object_test.rb /builddir/build/SOURCES/disable_storage_object_test.patch
patch unexpectedly ends in middle of line
Comment 7 errata-xmlrpc 2012-05-15 15:33:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0600.html

Note You need to log in before you can comment on or make changes to this bug.