Bug 802898 - --spice-color-depth=16 does not seem to work
--spice-color-depth=16 does not seem to work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 13:09 EDT by Marian Krcmarik
Modified: 2012-06-20 08:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Krcmarik 2012-03-13 13:09:59 EDT
Description of problem:
remote-viewer spice://localhost?port=3010 --spice-color-depth=16 does not seem to work while spicec -h localhost -p 3010 --color-depth=16 works with the same guest.

Version-Release number of selected component (if applicable):
spice-gtk-0.11-1.el6.x86_64
spice-xpi-2.7-11.el6.x86_64
spice-protocol-0.10.1-1.el6.noarch
spice-glib-0.11-1.el6.x86_64
spice-gtk-tools-0.11-1.el6.x86_64
virt-viewer-0.5.2-1.el6.x86_64

How reproducible:
Always 

Steps to Reproduce:
1. Connect to Windows guest with remote-viewer and --spice-color-depth=16 option (guest has to have spice vdagent running).
  
Actual results:
16bit color depth should be set

Expected results:
32 color depth is set

Additional info:
Comment 2 Marc-Andre Lureau 2012-03-16 18:50:07 EDT
Proposed patch fixing bug sent to spice-devel ML:
http://lists.freedesktop.org/archives/spice-devel/2012-March/008012.html
Comment 7 Marc-Andre Lureau 2012-04-20 09:23:33 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 9 errata-xmlrpc 2012-06-20 08:19:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0767.html

Note You need to log in before you can comment on or make changes to this bug.