Bug 802908 - [RFE] Scalability Testing: Functionality degrades when scaling up load from 120 users to 200 users
[RFE] Scalability Testing: Functionality degrades when scaling up load from 1...
Status: CLOSED WONTFIX
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Linux
unspecified Severity high
: rc
: ---
Assigned To: Angus Thomas
Rehana
: FutureFeature, Triaged
: 802975 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 14:14 EDT by Ronelle Landy
Modified: 2014-04-17 19:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 19:58:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Service Unavailable ... trying to access conductor with 200 users logged in (43.93 KB, image/png)
2012-03-13 14:17 EDT, Ronelle Landy
no flags Details
results - 120 users (163.09 KB, text/csv)
2012-03-13 14:23 EDT, Ronelle Landy
no flags Details
results - 200 users (293.24 KB, text/csv)
2012-03-13 14:24 EDT, Ronelle Landy
no flags Details
proxy error - from trying to access conductor/pools (49.32 KB, image/png)
2012-03-13 14:51 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Ronelle Landy 2012-03-13 14:14:45 EDT
Description of problem:

120 users logged in to one conductor instance (log in times separated by 5 seconds) can each:
 - create an application blueprint
 - launch an instance from that blueprint (using mock provider)
 - go to the monitor page and see the launched instances (although time to bring up the monitor page grows - logged in a separate BZ)

(See jmeter test output 'csv file' resultsTable120.csv)

Scaling that up to 200 users and conductor no longer operates and launch all the required instances successfully. Tried this test twice. 
 - In the first attempt, 0 instances were launched ( See jmeter test output 'csv file' resultsTable200_0.csv)
 - In the second attempt, 3 instances were launched but even access the conductor/users page starts to throw 503 "Service Temporarily Unavailable" errors. (See See jmeter test output 'csv file' resultsTable200_0.csv)

rpms tested:

rpm -qa |grep aeolus
rubygem-aeolus-cli-0.3.0-14.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
aeolus-all-0.8.0-41.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.0-41.el6.noarch
aeolus-conductor-daemons-0.8.0-41.el6.noarch
aeolus-conductor-doc-0.8.0-41.el6.noarch
Comment 1 Ronelle Landy 2012-03-13 14:17:17 EDT
Created attachment 569746 [details]
Service Unavailable ... trying to access conductor with 200 users logged in
Comment 2 Ronelle Landy 2012-03-13 14:23:13 EDT
Created attachment 569748 [details]
results - 120 users
Comment 3 Ronelle Landy 2012-03-13 14:24:29 EDT
Created attachment 569749 [details]
results - 200 users
Comment 4 Ronelle Landy 2012-03-13 14:51:26 EDT
Created attachment 569758 [details]
proxy error - from trying to access conductor/pools
Comment 5 wes hayutin 2012-04-30 11:48:07 EDT
*** Bug 802975 has been marked as a duplicate of this bug. ***
Comment 6 Hugh Brock 2012-05-08 12:25:33 EDT
Will hold off for first z, large #s of concurrent users are not a high priority for this release.

Note You need to log in before you can comment on or make changes to this bug.