Bug 803060 - SELinux is preventing /usr/bin/evince from 'create' accesses on the file 0001494v1.pdf.
SELinux is preventing /usr/bin/evince from 'create' accesses on the file 0001...
Status: CLOSED DUPLICATE of bug 803058
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:15dab59e3aee3d1aff53d15e621...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 17:17 EDT by Joachim Frieben
Modified: 2012-03-14 05:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-14 05:50:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2012-03-13 17:17:52 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-0.rc7.git0.2.fc17.x86_64
reason:         SELinux is preventing /usr/bin/evince from 'create' accesses on the file 0001494v1.pdf.
time:           Tue 13 Mar 2012 10:17:42 PM CET

description:
:SELinux is preventing /usr/bin/evince from 'create' accesses on the file 0001494v1.pdf.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that evince should be allowed create access on the 0001494v1.pdf file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep EvJobScheduler /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                0001494v1.pdf [ file ]
:Source                        EvJobScheduler
:Source Path                   /usr/bin/evince
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           evince-3.3.90-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-95.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-0.rc7.git0.2.fc17.x86_64 #1 SMP
:                              Mon Mar 12 16:56:58 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    Tue 13 Mar 2012 02:11:21 PM CET
:Last Seen                     Tue 13 Mar 2012 09:07:25 PM CET
:Local ID                      c9e119cd-9d33-4f65-87c4-536328bf19fd
:
:Raw Audit Messages
:type=AVC msg=audit(1331669245.995:92): avc:  denied  { create } for  pid=2120 comm="EvJobScheduler" name="0001494v1.pdf" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1331669245.995:92): arch=x86_64 syscall=open success=no exit=EACCES a0=7f31000a8000 a1=c1 a2=1b6 a3=aaaaaaaaaaaaaaab items=0 ppid=2108 pid=2120 auid=1001 uid=1001 gid=100 euid=1001 suid=1001 fsuid=1001 egid=100 sgid=100 fsgid=100 tty=(none) ses=2 comm=EvJobScheduler exe=/usr/bin/evince subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: EvJobScheduler,mozilla_plugin_t,user_home_dir_t,file,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-03-14 05:50:27 EDT

*** This bug has been marked as a duplicate of bug 803058 ***

Note You need to log in before you can comment on or make changes to this bug.