This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 803061 - SELinux is preventing /usr/bin/mozplugger-helper from using the 'getsession' accesses on a process.
SELinux is preventing /usr/bin/mozplugger-helper from using the 'getsession' ...
Status: CLOSED DUPLICATE of bug 803058
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:1e3bfd3bfae917c966c00e80a3f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 17:18 EDT by Joachim Frieben
Modified: 2012-03-14 05:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-14 05:50:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2012-03-13 17:18:25 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-0.rc7.git0.2.fc17.x86_64
reason:         SELinux is preventing /usr/bin/mozplugger-helper from using the 'getsession' accesses on a process.
time:           Tue 13 Mar 2012 10:18:15 PM CET

description:
:SELinux is preventing /usr/bin/mozplugger-helper from using the 'getsession' accesses on a process.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that mozplugger-helper should be allowed getsession access on processes labeled mozilla_plugin_t by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep mozplugger-help /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Objects                 [ process ]
:Source                        mozplugger-help
:Source Path                   /usr/bin/mozplugger-helper
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           mozplugger-1.14.3-2.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-95.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-0.rc7.git0.2.fc17.x86_64 #1 SMP
:                              Mon Mar 12 16:56:58 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Tue 13 Mar 2012 09:31:16 AM CET
:Last Seen                     Tue 13 Mar 2012 09:31:17 AM CET
:Local ID                      2ff596a8-0bbc-4e7a-9846-85e51d152b57
:
:Raw Audit Messages
:type=AVC msg=audit(1331627477.233:70): avc:  denied  { getsession } for  pid=2055 comm="mozplugger-help" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tclass=process
:
:
:type=SYSCALL msg=audit(1331627477.233:70): arch=x86_64 syscall=getsid success=no exit=EACCES a0=7fc a1=7fc a2=31fa1af768 a3=11 items=0 ppid=1991 pid=2055 auid=1001 uid=1001 gid=100 euid=1001 suid=1001 fsuid=1001 egid=100 sgid=100 fsgid=100 tty=(none) ses=2 comm=mozplugger-help exe=/usr/bin/mozplugger-helper subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: mozplugger-help,mozilla_plugin_t,mozilla_plugin_t,process,getsession
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-03-14 05:50:31 EDT

*** This bug has been marked as a duplicate of bug 803058 ***

Note You need to log in before you can comment on or make changes to this bug.