This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 803107 - [abrt] ibus-1.4.1-1.fc16: Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
[abrt] ibus-1.4.1-1.fc16: Process /usr/bin/ibus-daemon was killed by signal 6...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:b1d4db52a4c87729964d40ea4fc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 21:22 EDT by Li Junshuai
Modified: 2012-03-14 03:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-14 03:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (9.33 KB, text/plain)
2012-03-13 21:22 EDT, Li Junshuai
no flags Details
File: maps (4.61 KB, text/plain)
2012-03-13 21:22 EDT, Li Junshuai
no flags Details

  None (edit)
Description Li Junshuai 2012-03-13 21:22:45 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/ibus-daemon -r --xim
executable:     /usr/bin/ibus-daemon
kernel:         3.2.9-2.fc16.i686.PAE
pid:            30146
pwd:            /tmp
reason:         Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
time:           Tue 13 Mar 2012 05:07:12 PM CST
uid:            1000
username:       lijunshuai
var_log_messages: Mar 13 17:07:12 labF abrt[32726]: Saved core dump of pid 30146 (/usr/bin/ibus-daemon) to /var/spool/abrt/ccpp-2012-03-13-17:07:12-30146 (26914816 bytes)

backtrace:      Text file, 9557 bytes
maps:           Text file, 4720 bytes

dso_list:
:/lib/libdl-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1331027161
:/lib/libgthread-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.i686 (Fedora Project) 1331027187
:/lib/libgio-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.i686 (Fedora Project) 1331027187
:/lib/libgmodule-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.i686 (Fedora Project) 1331027187
:/lib/libresolv-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1331027161
:/usr/lib/libibus-1.0.so.0.401.0 ibus-libs-1.4.1-1.fc16.i686 (Fedora Project) 1331027230
:/lib/librt-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1331027161
:/lib/libpthread-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1331027161
:/lib/ld-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1331027161
:/lib/libselinux.so.1 libselinux-2.1.6-6.fc16.i686 (Fedora Project) 1331027185
:/usr/bin/ibus-daemon ibus-1.4.1-1.fc16.i686 (Fedora Project) 1331028210
:/usr/lib/libffi.so.5.0.10 libffi-3.0.10-1.fc16.i686 (Fedora Project) 1320287717
:/lib/libz.so.1.2.5 zlib-1.2.5-6.fc16.i686 (Fedora Project) 1331027185
:/lib/libnss_files-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1331027161
:/lib/libglib-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.i686 (Fedora Project) 1331027187
:/lib/libgobject-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.i686 (Fedora Project) 1331027187
:/lib/libc-2.14.90.so glibc-2.14.90-24.fc16.6.i686 (Fedora Project) 1331027161
:/usr/lib/locale/locale-archive glibc-common-2.14.90-24.fc16.6.i686 (Fedora Project) 1331027152

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-ZmsZbO6YNT,guid=b1324c17797347c8fc80a20900011259
:XDG_SESSION_COOKIE=108f5d215276b884ac0cc70000000009-1331627406.547278-897729722
:XDG_RUNTIME_DIR=/run/user/lijunshuai
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GDMSESSION=gnome
:XDG_VTNR=1
:USERNAME=lijunshuai
:XDG_SESSION_ID=33
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ZmsZbO6YNT,guid=b1324c17797347c8fc80a20900011259
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-lijunshuai-Cqw4TJ/database
:USER=lijunshuai
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=29594
:SHLVL=1
:GDM_LANG=en_US.utf8
:PWD=/home/lijunshuai
:GNOME_KEYRING_CONTROL=/tmp/keyring-8z5zFI
:LANG=en_US.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=lijunshuai
:HOME=/home/lijunshuai
:LC_CTYPE=en_US.utf8
:GTK_IM_MODULE=ibus
:QT_IM_MODULE=ibus
:XMODIFIERS=@im=ibus

smolt_data:
:
:
:General
:=================================
:UUID: 0c1b8d45-3791-449a-80a8-0709b96b47e6
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: i686
:BogoMIPS: 5186.89
:CPU Vendor: GenuineIntel
:CPU Model: Pentium(R) Dual-Core  CPU      E5300  @ 2.60GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2603
:System Memory: 2004
:System Swap: 0
:Vendor: LENOVO
:System: QiTianM6900 Lenovo
:Form factor: Desktop
:Kernel: 3.2.9-2.fc16.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10168:6058:12346) pci, None, PCI/ISA, 82801GB/GR (ICH7 Family) LPC Interface Bridge
:(4523:17252:6058:12346) pci, sky2, ETHERNET, 88E8056 PCI-E Gigabit Ethernet Controller
:(32902:10690:6058:12346) pci, i915, VIDEO, 82G33/G31 Express Integrated Graphics Controller
:(32902:10176:6058:12346) pci, ata_piix, STORAGE, N10/ICH7 Family SATA IDE Controller
:(32902:10192:6058:12346) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:6058:12346) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(32902:10200:6058:12346) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10202:6058:12346) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:9294:6058:12346) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:10185:6058:12346) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:6058:12346) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:10688:6058:12346) pci, agpgart-intel, HOST/PCI, 82G33/G31/P35/P31 Express DRAM Controller
:(32902:10186:6058:12346) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10187:6058:12346) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:6058:12346) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 5231203 1769664 1717241 1297920 822272 822272
:/dev/sda2 WITHHELD fuseblk 4096 4096 60315647 14091137 14091137 56659460 56408070 56408070
:
Comment 1 Li Junshuai 2012-03-13 21:22:49 EDT
Created attachment 569824 [details]
File: backtrace
Comment 2 Li Junshuai 2012-03-13 21:22:51 EDT
Created attachment 569825 [details]
File: maps
Comment 3 fujiwara 2012-03-13 21:47:58 EDT
I cannot reproduce your assertion failure below.
Do you still reproduce your problem?


(In reply to comment #1)
> Created attachment 569824 [details]
> File: backtrace

#0  0xb7781424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x4b19398f in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = <optimized out>
        resultvar = <optimized out>
        pid = 1261494260
        selftid = 30146
#2  0x4b1952d5 in __GI_abort () at abort.c:91
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x4b413a26 <standard_realloc+6>, sa_sigaction = 0x4b413a26 <standard_realloc+6>}, sa_mask = {__val = {1261495264, 1262659775, 160083432, 0, 1, 1262680690, 160842008, 160354304, 1, 1263448052, 160841984, 160841984, 160354304, 1262567628, 0, 3216327788, 1262659529, 1263448052, 160456768, 1262567606, 1263448052, 1262568391, 160841984, 160456768, 160354304, 1260239129, 1263448052, 1263448052, 144, 1262693166, 160841984, 0}}, sa_flags = -1078639508, sa_restorer = 0x4}
        sigs = {__val = {32, 0 <repeats 31 times>}}
#3  0x4b43307f in g_assertion_message (domain=0x4e16b2e1 "GLib-GIO", file=0x4e186af9 "gdbusconnection.c", line=4615, func=0x4e188503 "call_in_idle_cb", message=<optimized out>) at gtestutils.c:1425
        lstr = "4615\000AAK\306\305BK\364\257NK\034\307BK\310P\226\tsKHK\364\257NK"
        s = 0x98ed000 "\370@\226\t\020\344\060K:ERROR:gdbusconnection.c:4615:call_in_idle_cb: assertion failed: (vtable != NULL && vtable->method_call != NULL)\200"
#4  0x4b433610 in g_assertion_message_expr (domain=0x4e16b2e1 "GLib-GIO", file=0x4e186af9 "gdbusconnection.c", line=4615, func=0x4e188503 "call_in_idle_cb", expr=0x4e187a18 "vtable != NULL && vtable->method_call != NULL") at gtestutils.c:1436
        s = <optimized out>
#5  0x4e12fcf4 in call_in_idle_cb (user_data=0x98ca950) at gdbusconnection.c:4615
        invocation = 0x98ca950 [GDBusMethodInvocation]
        vtable = 0x98ffe60
        registration_id = <optimized out>
        subtree_registration_id = <optimized out>
        __PRETTY_FUNCTION__ = "call_in_idle_cb"
Comment 4 Li Junshuai 2012-03-14 02:30:36 EDT
Thanks for your attention, but i don´t know how the crash happen either, and for now it had not happen again


(In reply to comment #3)
> I cannot reproduce your assertion failure below.
> Do you still reproduce your problem?
> 
> 
> (In reply to comment #1)
> > Created attachment 569824 [details]
> > File: backtrace
> 
> #0  0xb7781424 in __kernel_vsyscall ()
> No symbol table info available.
> #1  0x4b19398f in __GI_raise (sig=6) at
> ../nptl/sysdeps/unix/sysv/linux/raise.c:64
>         resultvar = <optimized out>
>         resultvar = <optimized out>
>         pid = 1261494260
>         selftid = 30146
> #2  0x4b1952d5 in __GI_abort () at abort.c:91
>         save_stage = 2
>         act = {__sigaction_handler = {sa_handler = 0x4b413a26
> <standard_realloc+6>, sa_sigaction = 0x4b413a26 <standard_realloc+6>}, sa_mask
> = {__val = {1261495264, 1262659775, 160083432, 0, 1, 1262680690, 160842008,
> 160354304, 1, 1263448052, 160841984, 160841984, 160354304, 1262567628, 0,
> 3216327788, 1262659529, 1263448052, 160456768, 1262567606, 1263448052,
> 1262568391, 160841984, 160456768, 160354304, 1260239129, 1263448052,
> 1263448052, 144, 1262693166, 160841984, 0}}, sa_flags = -1078639508,
> sa_restorer = 0x4}
>         sigs = {__val = {32, 0 <repeats 31 times>}}
> #3  0x4b43307f in g_assertion_message (domain=0x4e16b2e1 "GLib-GIO",
> file=0x4e186af9 "gdbusconnection.c", line=4615, func=0x4e188503
> "call_in_idle_cb", message=<optimized out>) at gtestutils.c:1425
>         lstr =
> "4615\000AAK\306\305BK\364\257NK\034\307BK\310P\226\tsKHK\364\257NK"
>         s = 0x98ed000
> "\370@\226\t\020\344\060K:ERROR:gdbusconnection.c:4615:call_in_idle_cb:
> assertion failed: (vtable != NULL && vtable->method_call != NULL)\200"
> #4  0x4b433610 in g_assertion_message_expr (domain=0x4e16b2e1 "GLib-GIO",
> file=0x4e186af9 "gdbusconnection.c", line=4615, func=0x4e188503
> "call_in_idle_cb", expr=0x4e187a18 "vtable != NULL && vtable->method_call !=
> NULL") at gtestutils.c:1436
>         s = <optimized out>
> #5  0x4e12fcf4 in call_in_idle_cb (user_data=0x98ca950) at
> gdbusconnection.c:4615
>         invocation = 0x98ca950 [GDBusMethodInvocation]
>         vtable = 0x98ffe60
>         registration_id = <optimized out>
>         subtree_registration_id = <optimized out>
>         __PRETTY_FUNCTION__ = "call_in_idle_cb"
Comment 5 fujiwara 2012-03-14 03:36:04 EDT
OK, thanks for the test.
If you could find the reproducing steps, please update this report again.

Note You need to log in before you can comment on or make changes to this bug.