Bug 803139 - guest fs become readonly filesystem after dd operation
guest fs become readonly filesystem after dd operation
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.9
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks: 807971
  Show dependency treegraph
 
Reported: 2012-03-13 22:52 EDT by Suqin Huang
Modified: 2012-04-12 11:11 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 04:29:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
call trace (15.68 KB, text/plain)
2012-03-13 22:52 EDT, Suqin Huang
no flags Details
fs checking error (19.74 KB, image/png)
2012-03-13 23:26 EDT, Suqin Huang
no flags Details

  None (edit)
Description Suqin Huang 2012-03-13 22:52:04 EDT
Created attachment 569854 [details]
call trace

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
sometime

Steps to Reproduce:
1. run dd in guest
for i in `seq 1000`; do dd if=/dev/zero of=/tmp/file bs=1M count=1024; done

2. [root@localhost ~]# touch test
touch test
touch: cannot touch `test': Read-only file system

3.
  
Actual results:


Expected results:


Additional info:

1. guest kernel: 2.6.18-308.el5

2. df
[root@localhost ~]# df
df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      16220072   3718980  11663872  25% /
/dev/vda1               101086     12848     83019  14% /boot
tmpfs                  2021628         0   2021628   0% /dev/shm

3. cmd
/usr/libexec/qemu-kvm -name 308_249 -monitor stdio -serial unix:/tmp/serial-20120313-002624-AuCO,server,nowait -drive file=/images/RHEL-Server-5.8-64-virtio.qcow2,index=0,if=virtio,media=disk,cache=none,boot=on,format=qcow2 -net nic,vlan=0,model=virtio,macaddr=90:0a:90:76:45:00 -net tap,vlan=0,script=/home/autotest-devel/client/tests/kvm/scripts/qemu-ifup-switch -m 4096 -smp 2,cores=1,threads=1,sockets=2 -cpu qemu64,+sse2 -soundhw ac97 -vnc :1 -rtc-td-hack -M rhel5.6.0 -boot c -no-kvm-pit-reinjection -usbdevice table

4. call trace (attached)
Comment 1 Suqin Huang 2012-03-13 23:05:32 EDT
(In reply to comment #0)
> Created attachment 569854 [details]
> call trace
> 
> Description of problem:
> 
> 
> Version-Release number of selected component (if applicable):

kvm-83-249.el5
2.6.18-308.el5
Comment 2 Suqin Huang 2012-03-13 23:26:37 EDT
Created attachment 569862 [details]
fs checking error
Comment 3 Ronen Hod 2012-03-14 19:29:57 EDT
Kevin,

Is it worth verifying on a native (non-virt) installation?
Comment 4 Kevin Wolf 2012-03-15 05:56:40 EDT
Suqin, what does qemu-img check say? Does the same happen with IDE or SCSI disks? And is "sometimes" more like 50% or more like 5%?

Ronen, if you can get us some real virtio-blk hardware, that would be cool. ;-)
Comment 5 Kevin Wolf 2012-03-15 05:57:49 EDT
Oh, I only see now that this is RHEL 5. So the next obvious question would be if you can observe the same on RHEL 6.
Comment 7 Suqin Huang 2012-03-26 03:47:20 EDT
#qemu-img check RHEL-Server-5.8-64-virtio.qcow2
No errors were found on the image.

issue always happen if the images installed (fresh installed)on host AMD 4450B, but don't happen if the image installed on other host when I report this bug.

will try with ide/virtio (do I need to test scsi? it's not supported on rhel5)
Comment 8 Kevin Wolf 2012-03-26 05:05:48 EDT
No, SCSI is not required, IDE should be good enough.

Does it happen with RHEL 6 guests as well?
Comment 9 Suqin Huang 2012-03-28 01:09:16 EDT
Hi kevin,
re-test it, don't reproduce it until now (both rhel5 and rhel6 guests)
but it's easy to reproduce with the backup image(fresh installed when I report this bug) both ide and virtio.

you can get image here 
http://fileshare.englab.nay.redhat.com/pub/section2/kvm/shuang/image/shuang.bak
Comment 11 RHEL Product and Program Management 2012-04-02 06:46:52 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 12 Ademar Reis 2012-04-09 18:28:09 EDT
Since it's been difficult to reproduce this problem with a fresh install, I recommend closing it as WONTFIX or WORKSFORME on RHEL5.
Comment 13 Kevin Wolf 2012-04-10 04:29:52 EDT
I agree, closing.

Note You need to log in before you can comment on or make changes to this bug.