Bug 803180 - Error logs despite not errors to user (client)
Error logs despite not errors to user (client)
Status: CLOSED DUPLICATE of bug 804301
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vinayaga Raman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 02:45 EDT by Sachidananda Urs
Modified: 2014-03-30 21:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-03 04:01:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2012-03-14 02:45:28 EDT
Description of problem:

A *lot* (amount to several GB of logs) of log messages fill the log file despite no error to user.

If below errors are benign they have to be moved to DEBUG.

I confirm this is a new volume and the export directory is not part of a deleted volume. Tried with fresh volumes.

=====================

[2012-03-14 06:59:51.546153] E [nfs3.c:1549:nfs3_access] 0-nfs-nfsv3: Failed to map FH to vol: client=10.1.10.25:950, exportid=bcdbab76-09c6-43a8-863e-fba26527fc8e, gfid=2dfdb20f-4370-4105-8f60-c5677a4aa177
[2012-03-14 06:59:51.546164] E [nfs3.c:1549:nfs3_access] 0-nfs-nfsv3: Stale nfs client 10.1.10.25:950 must be trying to connect to a deleted volume, please unmount it.
[2012-03-14 06:59:51.546176] W [nfs3-helpers.c:3392:nfs3_log_common_res] 0-nfs-nfsv3: XID: 27fead36, ACCESS: NFS: 70(Invalid file handle), POSIX: 14(Bad address)
[2012-03-14 06:59:51.546218] E [nfs3.c:1405:nfs3_lookup] 0-nfs-nfsv3: Failed to map FH to vol: client=10.1.10.25:950, exportid=bcdbab76-09c6-43a8-863e-fba26527fc8e, gfid=2dfdb20f-4370-4105-8f60-c5677a4aa177
[2012-03-14 06:59:51.546230] E [nfs3.c:1405:nfs3_lookup] 0-nfs-nfsv3: Stale nfs client 10.1.10.25:950 must be trying to connect to a deleted volume, please unmount it.
[2012-03-14 06:59:51.546242] W [nfs3-helpers.c:3392:nfs3_log_common_res] 0-nfs-nfsv3: XID: 28fead36, LOOKUP: NFS: 70(Invalid file handle), POSIX: 14(Bad address)
[2012-03-14 06:59:51.546297] E [nfs3.c:305:__nfs3_get_volume_id] (-->/opt/glusterfs/3.3.0qa27/lib/glusterfs/3.3.0qa27/xlator/nfs/server.so(nfs3_lookup+0x18c) [0x7fba4cf14cec] (-->/opt/glusterfs/3.3.0qa27/lib/glusterfs/3.3.0qa27/xlator/nfs/server.so(nfs3_lookup_reply+0x4d) [0x7fba4cf0b8bd] (-->/opt/glusterfs/3.3.0qa27/lib/glusterfs/3.3.0qa27/xlator/nfs/server.so(nfs3_request_xlator_deviceid+0x43) [0x7fba4cf0a513]))) 0-nfs-nfsv3: invalid argument: xl
[2012-03-14 06:59:51.546336] E [nfs3.c:1549:nfs3_access] 0-nfs-nfsv3: Failed to map FH to vol: client=10.1.10.25:950, exportid=bcdbab76-09c6-43a8-863e-fba26527fc8e, gfid=2dfdb20f-4370-4105-8f60-c5677a4aa177
[2012-03-14 06:59:51.546348] E [nfs3.c:1549:nfs3_access] 0-nfs-nfsv3: Stale nfs client 10.1.10.25:950 must be trying to connect to a deleted volume, please unmount it.
[2012-03-14 06:59:51.546360] W [nfs3-helpers.c:3392:nfs3_log_common_res] 0-nfs-nfsv3: XID: 29fead36, ACCESS: NFS: 70(Invalid file handle), POSIX: 14(Bad address)
[2012-03-14 06:59:51.546390] E [nfs3.c:1549:nfs3_access] 0-nfs-nfsv3: Failed to map FH to vol: client=10.1.10.25:950, exportid=bcdbab76-09c6-43a8-863e-fba26527fc8e, gfid=2dfdb20f-4370-4105-8f60-c5677a4aa177
[2012-03-14 06:59:51.546402] E [nfs3.c:1549:nfs3_access] 0-nfs-nfsv3: Stale nfs client 10.1.10.25:950 must be trying to connect to a deleted volume, please unmount it.
[2012-03-14 06:59:51.546414] W [nfs3-helpers.c:3392:nfs3_log_common_res] 0-nfs-nfsv3: XID: 2afead36, ACCESS: NFS: 70(Invalid file handle), POSIX: 14(Bad address)
[2012-03-14 06:59:51.546449] E [nfs3.c:1549:nfs3_access] 0-nfs-nfsv3: Failed to map FH to vol: client=10.1.10.25:950, exportid=bcdbab76-09c6-43a8-863e-fba26527fc8e, gfid=2dfdb20f-4370-4105-8f60-c5677a4aa177
[2012-03-14 06:59:51.546461] E [nfs3.c:1549:nfs3_access] 0-nfs-nfsv3: Stale nfs client 10.1.10.25:950 must be trying to connect to a deleted volume, please unmount it.
[2012-03-14 06:59:51.546477] W [nfs3-helpers.c:3392:nfs3_log_common_res] 0-nfs-nfsv3: XID: 2bfead36, ACCESS: NFS: 70(Invalid file handle), POSIX: 14(Bad address)
[2012-03-14 06:59:51.546509] E [nfs3.c:1549:nfs3_access] 0-nfs-nfsv3: Failed to map FH to vol: client=10.1.10.25:950, exportid=bcdbab76-09c6-43a8-863e-fba26527fc8e, gfid=2dfdb20f-4370-4105-8f60-c5677a4aa177
[2012-03-14 06:59:51.546521] E [nfs3.c:1549:nfs3_access] 0-nfs-nfsv3: Stale nfs client 10.1.10.25:950 must be trying to connect to a deleted volume, please unmount it.
[2012-03-14 06:59:51.546533] W [nfs3-helpers.c:3392:nfs3_log_common_res] 0-nfs-nfsv3: XID: 2cfead36, ACCESS: NFS: 70(Invalid file handle), POSIX: 14(Bad address)
[2012-03-14 06:59:51.546565] E [nfs3.c:1549:nfs3_access] 0-nfs-nfsv3: Failed to map FH to vol: client=10.1.10.25:950, exportid=bcdbab76-09c6-43a8-863e-fba26527fc8e, gfid=2dfdb20f-4370-4105-8f60-c5677a4aa177
[2012-03-14 06:59:51.546576] E [nfs3.c:1549:nfs3_access] 0-nfs-nfsv3: Stale nfs client 10.1.10.25:950 must be trying to connect to a deleted volume, please unmount it.
[2012-03-14 06:59:51.546594] W [nfs3-helpers.c:3392:nfs3_log_common_res] 0-nfs-nfsv3: XID: 2dfead36, ACCESS: NFS: 70(Invalid file handle), POSIX: 14(Bad address)
[2012-03-14 06:59:51.546624] E [nfs3.c:1405:nfs3_lookup] 0-nfs-nfsv3: Failed to map FH to vol: client=10.1.10.25:950, exportid=bcdbab76-09c6-43a8-863e-fba26527fc8e, gfid=2dfdb20f-4370-4105-8f60-c5677a4aa177
Comment 1 Sachidananda Urs 2012-03-14 02:52:15 EDT
This causes the server to slow down and processes seem to run forever on clients.
Comment 2 Krishna Srinivas 2012-04-03 04:01:18 EDT

*** This bug has been marked as a duplicate of bug 804301 ***

Note You need to log in before you can comment on or make changes to this bug.