Bug 803221 - Wrong error message when creating a domain using "openshift" name.
Wrong error message when creating a domain using "openshift" name.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 04:58 EDT by Yujie Zhang
Modified: 2015-05-14 21:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:32:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2012-03-14 04:58:09 EDT
Description of problem:

Wrong error message when creating a domain using "openshift" name.

Version-Release number of selected component (if applicable):

devenv_1661

How reproducible:always


Steps to Reproduce:
1.Go to new openshift website and login
2.Go to the app/console/applications page
3.Try to create a domain using "openshift" name
  
Actual results:

Error message "Namespace 'openshift' already in use. Please choose another." will come out.

Expected results:

The error message should be "Namespace 'openshift' is not allowed."

Additional info:
Comment 1 Clayton Coleman 2012-03-14 09:57:18 EDT
Validation in the REST API should return this message to the client.
Comment 2 Xiaoli Tian 2012-03-15 03:40:14 EDT
Move it to ON_QA, since we found the fix in devenv_1662.
Comment 3 Xiaoli Tian 2012-03-15 03:40:52 EDT
Verified it on devenv_1662,the error message becomes: The supplied application name 'openshift' is not allowed

Note You need to log in before you can comment on or make changes to this bug.