This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 803244 - input method switch (Ctrl+Space) is not working with gnome-shell overview or run dialog
input method switch (Ctrl+Space) is not working with gnome-shell overview or ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 06:07 EDT by A S Alam
Modified: 2013-07-02 21:10 EDT (History)
6 users (show)

See Also:
Fixed In Version: ibus-1.4.99.20120428-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-06 00:55:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 658325 None None None Never

  None (edit)
Description A S Alam 2012-03-14 06:07:54 EDT
Description of problem:
input method switch (Crtl+Space) is not working with gnome-shell while pressing Alt+F2 and Application Search (Windows key and Search). User is not able to change input method back to English.

Version-Release number of selected component (if applicable):
ibus-1.4.99.20120304-3.fc17.x86_64
ibus-anthy-1.3.99.20120304-1.fc17.x86_64
ibus-chewing-1.3.10-3.fc17.x86_64
ibus-gnome3-1.4.99.20120304-3.fc17.x86_64
ibus-gtk2-1.4.99.20120304-3.fc17.x86_64
ibus-gtk3-1.4.99.20120304-3.fc17.x86_64
ibus-hangul-1.4.0-5.fc17.x86_64
ibus-libs-1.4.99.20120304-3.fc17.x86_64
ibus-m17n-1.3.3-9.fc17.x86_64
ibus-pinyin-1.4.0-14.fc17.x86_64

gnome-shell-3.3.90-1.fc17.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Select some input with ibus (suppose Punjabi Inscript) (with Ctrl+Space)
2. Alt+F2 or Windows Key
3. try to switch input method
  
Actual results:
not able to switch input language by pressing Ctrl+Space with using of Alt+F2 

Expected results:
user should be able to switch language with Ctrl+Space while pressing Alt+F2 and application search (with Windows Key)

Additional info:
Comment 2 fujiwara 2012-04-27 07:02:10 EDT
I decided the Control+space only is fixed in this bug:
https://github.com/fujiwarat/ibus-gjs/commit/bc00708b9d80602483eb30a29fc16c56188eaab3

Since the IME switcher window cannot grab keyboard events, I disabled to show the switcher UI and just switch prev-next engines in shell entry boxes.

The upstream bugs about preedit visible and commitment won't be fixed in f17 and will be separated bugs.
Comment 3 Fedora Update System 2012-04-28 04:07:18 EDT
ibus-1.4.99.20120428-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-1.4.99.20120428-1.fc17
Comment 4 Fedora Update System 2012-04-28 13:11:34 EDT
Package ibus-1.4.99.20120428-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.4.99.20120428-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6889/ibus-1.4.99.20120428-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-05-06 00:55:14 EDT
ibus-1.4.99.20120428-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Jian He 2012-06-06 09:47:27 EDT
It seems this bug dos not solved?

# yum list ibus
Installed Packages
ibus.x86_64                   1.4.99.20120428-2.fc17                    @updates

but also has this issue.
Comment 7 fujiwara 2012-06-06 22:21:43 EDT
(In reply to comment #6)
> It seems this bug dos not solved?

I think you need to enable ibus-gnome3 with gnome-tweak-tool.
Comment 8 Jian He 2012-06-10 22:22:59 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > It seems this bug dos not solved?
> 
> I think you need to enable ibus-gnome3 with gnome-tweak-tool.

ahh, yes. It works after yum install ibus-gnome3 and enable the Input-Method Status Indicator Extension in gnome-tweak-tool.

Note You need to log in before you can comment on or make changes to this bug.