Bug 803304 - missing sync_plan & product relation methods in CLI
missing sync_plan & product relation methods in CLI
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium (vote)
: Unspecified
: --
Assigned To: Mike McCune
Garik Khachikyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 08:04 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:38:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2012-03-14 08:04:38 EDT
Description of problem:
There are methods to set_plan and remove_plan for the product but no way currently to list the sync plans that product assigned to and list the products for particular test_plan.

Version-Release number of selected component (if applicable):
recent CFSE Beta5 & latest Katello

How reproducible:
always

Steps to Reproduce:
1.prepare a sync plan and set to any custom product.
2.try to find a way via CLI to list that info
3.
  
Actual results:
there is no way to find relation between product & sync_plan.

Expected results:
possible to find realtion of product/sync_plan

Additional info:
Comment 2 Mike McCune 2012-08-28 14:53:52 EDT
You can currently view the Sync Plan for any given product:

$ katello -u admin -p admin product list
--------------------------------------------------------------------------------
      Product List For Organization ACME_Corporation, Environment 'dev'

 Id              Name   Provider Id   Provider Name   Sync Plan Name   Last Sync             GPG key  
--------------------------------------------------------------------------------
 1345524714613   zoo    2             custom-one      plan1            2012/08/28 00:00:06            


Will add a list of products to the 'sync_plan info' command:

$ katello -u admin -p admin sync_plan info --name=plan1
--------------------------------------------------------------------------------
                                Sync Plan Info
--------------------------------------------------------------------------------

Id                  :          1
Name                :        plan1
Description         :
    None
Start date          :  2012/08/28 00:00:00
Interval            :    daily
Products Using Plan :    
             zoo
             foobar
             ACME Custom Prod1
Comment 3 Mike McCune 2012-09-10 11:26:01 EDT
moving to 2.0
Comment 4 Mike McCune 2014-03-18 13:38:21 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.