Bug 803328 - [fa5b0347193f8d1a4b917a2edb338423cb175e66] ls after add-brick returns EINVAL
[fa5b0347193f8d1a4b917a2edb338423cb175e66] ls after add-brick returns EINVAL
Status: CLOSED DUPLICATE of bug 802233
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra G
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 09:05 EDT by Anush Shetty
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 23:32:42 EDT
Type: ---
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2012-03-14 09:05:39 EDT
Description of problem: After adding a brick to a single export volume, ls on the fuse mount returned EINVAL


Version-Release number of selected component (if applicable): Upstream


How reproducible: Consistently


Steps to Reproduce:
1. touch /mnt/gluster/dot
2. gluster volume add-brick test2 shortwing:/falcon/d3
3. ls /mnt//gluster
  
Actual results:

root@shortwing:/mnt/gluster# gluster volume add-brick test2 shortwing:/falcon/d3
Add Brick successful
root@shortwing:/mnt/gluster# ls
dot
root@shortwing:/mnt/gluster# ls
dot
root@shortwing:/mnt/gluster# ls
dot
root@shortwing:/mnt/gluster# ls
dot
root@shortwing:/mnt/gluster# ls
dot
root@shortwing:/mnt/gluster# ls
dot
root@shortwing:/mnt/gluster# ls
dot
root@shortwing:/mnt/gluster# ls
ls: reading directory .: Bad file descriptor
root@shortwing:/mnt/gluster# ls
ls: cannot access dot: Invalid argument
dot
root@shortwing:/mnt/gluster# ls
ls: cannot access dot: Invalid argument
dot
root@shortwing:/mnt/gluster# ls
ls: cannot access dot: Invalid argument
dot
root@shortwing:/mnt/gluster# ls
ls: cannot access dot: Invalid argument
dot
root@shortwing:/mnt/gluster# 



Expected results:


Additional info:

Client log-

[2012-03-14 18:30:59.150627] D [dht-common.c:438:dht_lookup_dir_cbk] 1-test2-dht: lookup of / on test2-client-1 returned error (Transport end
point is not connected)
[2012-03-14 18:30:59.150802] I [dht-layout.c:600:dht_layout_normalize] 1-test2-dht: found anomalies in /. holes=1 overlaps=0
[2012-03-14 18:30:59.150827] D [dht-layout.c:614:dht_layout_normalize] 1-test2-dht: path=/ err=Transport endpoint is not connected on subvol=
test2-client-1
[2012-03-14 18:30:59.150847] D [dht-common.c:486:dht_lookup_dir_cbk] 1-test2-dht: fixing assignment on /
[2012-03-14 18:30:59.150869] W [dht-selfheal.c:834:dht_selfheal_directory] 1-test2-dht: 1 subvolumes down -- not fixing
[2012-03-14 18:30:59.169700] D [dht-common.c:269:dht_discover_cbk] 1-test2-dht: lookup of  on test2-client-1 returned error (Transport endpoint is not connected)
[2012-03-14 18:30:59.169991] I [dht-layout.c:600:dht_layout_normalize] 1-test2-dht: found anomalies in . holes=1 overlaps=0
[2012-03-14 18:30:59.170025] D [dht-layout.c:614:dht_layout_normalize] 1-test2-dht: path= err=Transport endpoint is not connected on subvol=test2-client-1
[2012-03-14 18:30:59.170046] D [dht-common.c:197:dht_discover_complete] 1-test2-dht: normalizing failed on 
[2012-03-14 18:30:59.170104] W [fuse-bridge.c:3561:fuse_migrate_fd] 0-glusterfs-fuse: name-less lookup of gfid (00000000-0000-0000-0000-000000000001) failed (Invalid argument)
[2012-03-14 18:30:59.170176] I [client.c:2092:notify] 0-test2-client-0: current graph is no longer active, destroying rpc_client 
[2012-03-14 18:30:59.170244] W [fuse-resolve.c:346:fuse_resolve_fd] 0-fuse-resolve: migration of fd (0x1bf6adc) did not complete, failing fop with EBADF
[2012-03-14 18:30:59.170375] D [socket.c:193:__socket_rwv] 0-test2-client-0: EOF from peer 127.0.1.1:24009
[2012-03-14 18:30:59.170399] D [socket.c:1521:__socket_proto_state_machine] 0-test2-client-0: reading from socket failed. Error (Transport endpoint is not connected), peer (127.0.1.1:24009)
[2012-03-14 18:30:59.170419] D [socket.c:1807:socket_event_handler] 0-transport: disconnecting now
[2012-03-14 18:30:59.170450] W [client.c:2016:client_rpc_notify] 0-test2-client-0: Registering a grace timer
[2012-03-14 18:30:59.170471] I [client.c:2031:client_rpc_notify] 0-test2-client-0: disconnected
[2012-03-14 18:30:59.170491] D [fuse-bridge.c:4113:notify] 0-fuse: got event 6 on graph 0
[2012-03-14 18:31:00.591972] D [dht-common.c:2518:dht_fd_cbk] 1-test2-dht: subvolume test2-client-1 returned -1 (Transport endpoint is not connected)
[2012-03-14 18:31:00.593073] W [dht-layout.c:195:dht_layout_search] 1-test2-dht: no subvolume for hash (value) = 1380055847
[2012-03-14 18:31:00.593104] D [dht-helper.c:385:dht_subvol_get_hashed] 1-test2-dht: could not find subvolume for path=/dot
[2012-03-14 18:31:00.593124] E [dht-common.c:1341:dht_lookup] 1-test2-dht: Failed to get hashed subvol for /dot
[2012-03-14 18:31:00.593151] W [fuse-bridge.c:272:fuse_entry_cbk] 0-glusterfs-fuse: 59: LOOKUP() /dot => -1 (Invalid argument)
[2012-03-14 18:31:00.593279] W [dht-layout.c:195:dht_layout_search] 1-test2-dht: no subvolume for hash (value) = 1380055847
[2012-03-14 18:31:00.593302] D [dht-helper.c:385:dht_subvol_get_hashed] 1-test2-dht: could not find subvolume for path=/dot
[2012-03-14 18:31:00.593342] E [dht-common.c:1341:dht_lookup] 1-test2-dht: Failed to get hashed subvol for /dot
Comment 1 Amar Tumballi 2012-03-25 03:14:24 EDT
Check if its already fixed.
Comment 2 Anush Shetty 2012-03-26 01:17:52 EDT
Still seen with 3.3.0qa31
Comment 3 Raghavendra G 2012-04-02 23:32:42 EDT

*** This bug has been marked as a duplicate of bug 803201 ***
Comment 4 Raghavendra G 2012-04-03 02:47:51 EDT

*** This bug has been marked as a duplicate of bug 802233 ***

Note You need to log in before you can comment on or make changes to this bug.