Bug 803356 - Behavior of "cp --backup" changed, not backing up individual files
Behavior of "cp --backup" changed, not backing up individual files
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: coreutils (Show other bugs)
5.7
i386 Linux
urgent Severity high
: rc
: ---
Assigned To: Ondrej Vasik
qe-baseos-daemons
: Patch, Regression, ZStream
Depends On: 801873
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 10:23 EDT by RHEL Product and Program Management
Modified: 2012-09-05 22:18 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An incomplete fix for behavior of the "mv --backup" command, that was released with the RHBA-2011:1074 errata advisory, caused the "cp --backup" command to work incorrectly. When used with a directory as a source argument, the "cp --backup" command did not backup individual files within the directory but whole directory. This update corrects this problem and the "--backup" feature of the "cp" utility now works as intended again.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 08:02:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2012-03-14 10:23:35 EDT
This bug has been copied from bug #801873 and has been proposed
to be backported to 5.8 z-stream (EUS).
Comment 8 Miroslav Svoboda 2012-03-15 12:23:49 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
An incomplete fix for behavior of the "mv --backup" command, that was released with the RHBA-2011:1074 errata advisory, caused the "cp --backup" command to work incorrectly. When used with a directory as a source argument, the "cp --backup" command did not backup individual files within the directory but whole directory. This update corrects this problem and the "--backup" feature of the "cp" utility now works as intended again.
Comment 10 errata-xmlrpc 2012-03-21 08:02:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0408.html

Note You need to log in before you can comment on or make changes to this bug.