Bug 803386 - display product ID in product details pane on sm-gui and cli
display product ID in product details pane on sm-gui and cli
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Shwetha Kallesh
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-14 11:39 EDT by Chris Duryee
Modified: 2012-06-20 09:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:07:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Product Id in the installed products tab under "Product's subscription details (118.17 KB, image/png)
2012-03-26 04:25 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description Chris Duryee 2012-03-14 11:39:25 EDT
Description of problem:

In https://bugzilla.redhat.com/show_bug.cgi?id=788940, we allowed products with the same name but different IDs to be created. During the demo, JC brought up that this can pose a problem if a system subscribes to the same product with two names, since we only display the product name. The user would be unable to differentiate between the two.

The only way to differentiate between products in this case would be by product ID. We can display it as an additional field in "subscription-manager list --installed", and in the gui under "Product's subscription details" pane on the "my installed software tab"
Comment 1 Alex Wood 2012-03-23 14:09:53 EDT
Committed da8244909dee1769ea36920a211df5f9e639f10f

Available subscription-manager-0.99.11+
Comment 3 Shwetha Kallesh 2012-03-26 04:25:10 EDT
Created attachment 572697 [details]
Product Id in the installed products tab under "Product's subscription details

moving to verified

RPM version:

[root@skallesh ~]# rpm -qa | grep subscription-manager
subscription-manager-debuginfo-0.99.12-1.el6.x86_64
subscription-manager-gnome-0.99.12-1.el6.x86_64
subscription-manager-0.99.12-1.el6.x86_64
subscription-manager-migration-0.99.12-1.el6.x86_64
subscription-manager-firstboot-0.99.12-1.el6.x86_64
subscription-manager-migration-data-1.12.1.1-1.git.6.ea6813e.el6.noarch


[root@skallesh ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Management Bits          
Product ID:           	37069                    
Version:              	1.0                      
Arch:                 	ALL                      
Status:               	Not Subscribed           
Starts:               	                         
Expires:              	                         

Product Name:         	Large File Support Bits  
Product ID:           	37068                    
Version:              	1.0                      
Arch:                 	ALL                      
Status:               	Not Subscribed           
Starts:               	                         
Expires:
Comment 5 errata-xmlrpc 2012-06-20 09:07:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.