Bug 803495 - Missing tomcat-api and tomcat-util POM files in tomcat-lib
Missing tomcat-api and tomcat-util POM files in tomcat-lib
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tomcat (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ivan Afonichev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 16:15 EDT by Juan Hernández
Modified: 2012-04-19 23:09 EDT (History)
5 users (show)

See Also:
Fixed In Version: tomcat-7.0.27-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 23:09:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to add the POM files (2.39 KB, patch)
2012-03-14 16:18 EDT, Juan Hernández
no flags Details | Diff

  None (edit)
Description Juan Hernández 2012-03-14 16:15:57 EDT
Description of problem:

The tomcat-lib package doesn't include the tomcat-api and tomcat-util packages. These are dependencies of tomcat-catalina, so building any package that requires tomcat-catalina fails.

Version-Release number of selected component (if applicable):

tomcat-lib-7.0.26-1.fc18.noarch

How reproducible:

Always.

Steps to Reproduce:

1. Build with any package that requires tomcat-catalina.
  
Actual results:

The build fails because of the missing dependencies.

Expected results:

The build should complete without errors.
Comment 1 Juan Hernández 2012-03-14 16:18:15 EDT
Created attachment 570096 [details]
Proposed patch to add the POM files
Comment 2 Fedora Update System 2012-04-09 17:54:33 EDT
tomcat-7.0.27-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/tomcat-7.0.27-2.fc17
Comment 3 Fedora Update System 2012-04-10 16:18:20 EDT
Package tomcat-7.0.27-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tomcat-7.0.27-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5589/tomcat-7.0.27-2.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-04-19 23:09:03 EDT
tomcat-7.0.27-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.