Bug 80353 - Probable memory leaks in anaconda
Probable memory leaks in anaconda
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-24 17:11 EST by jfm2
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 17:41:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jfm2 2002-12-24 17:11:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i586; U;) Gecko/20020830

Description of problem:
By the end of installation anaconda was using 250 megs of main memory and 170
megs of swap for a total of 420 megs.  My guess is that it does
not free the memory for the photos.  There are many of them and they
change frequently.  They are very nice but if you don't find where anaconda is
leaking you should consider reducing their number and frequency of reloading.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install in graphic mode
2. Run free from time to time during the installation
3.
    

Additional info:
Comment 1 Jeremy Katz 2003-01-02 16:16:37 EST
There were some leaks in the version of pygtk2 used in phoebe.  1.99.14 fixes these
Comment 2 Mike McLean 2003-01-13 20:01:42 EST
this seems to be fixed
Comment 3 jfm2 2003-01-23 02:14:13 EST
In Phoebe2 by the end of installation it was using some 350 megs of memory+swap
(I installed less things than when I opened the bug).
Checks during the installation showed constant increase during package
installation phase
Comment 4 Mike McLean 2003-01-24 17:41:20 EST
The output of free (or contents of /proc/meminfo) can be misleading.  How the
kernel manages physical resources like memory and swap space is separate from
how anaconda (or any other userland process) manages the memory allocated to it
by the kernel. 

The best indication of anaconda's memory use is /proc/$PID/status, where $PID is
the pid of anaconda.  I have run some additional tests and anaconda does not
appear to be leaking memory in Phoebe public beta 2.

Usually when anaconda does have a memory leak (and I think there was a minor one
in Phoebe public beta 1), I will see a few of my testcases stall out completely,
particularly some of the low-memory testcases.  I did not see this with the
second public beta.

Re-closing this bug.

Note You need to log in before you can comment on or make changes to this bug.