Bug 803568 - Use virt-v2v to convert VM with SDL display type, the display type should be changed to the type which qemu-kvm support
Use virt-v2v to convert VM with SDL display type, the display type should be ...
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 00:57 EDT by tingting zheng
Modified: 2014-11-18 06:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 06:27:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2012-03-15 00:57:58 EDT
Description of problem:
From rhel6,qemu-kvm and libvirt don't support SDL display type,when using virt-v2v to convert VM with SDL display type,the display type should be changed to the type which qemu-kvm support

Version-Release number of selected component (if applicable):
virt-v2v-0.8.7-4.el6.x86_64
libvirt-0.9.10-5.el6.x86_64
llibguestfs-1.16.8-1.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1.Configure a guest with SDL display type

2.Use virt-v2v to convert the guest.
# virt-v2v  -ic qemu+ssh://10.66.72.122/system -os default  -b breth0 kvm-rhel5.6-i386
rhel5u6-32b-raw-kvm-no-rhn: 100% [================================================================================]D 0h01m55s
virt-v2v: kvm-rhel5.6-i386 configured with virtio drivers.

3.After conversion,check the display type of the guest and start the guest.
# virsh dumpxml kvm-rhel5.6-i386 |grep "graphics type"
    <graphics type='sdl'/>
# virsh start kvm-rhel5.6-i386
error: Failed to start domain kvm-rhel5.6-i386
error: unsupported configuration: sdl not supported by '/usr/libexec/qemu-kvm'

Actual results:
The display type of the guest is SDL,which is not supported by qemu-kvm and libvirt.


Expected results:
The display type should be changed to the type which qemu-kvm support,eg:vnc.
Or some messages should be printd to give tips:As qemu-kvm doesn't support SDL display type,so the type will become VNC after conversion.


Additional info:
qemu-kvm and libvirt don't support SDL display type.
Refer Bug 633326 - Fails to reject unsupported graphics type such as 'sdl'
Comment 2 RHEL Product and Program Management 2012-05-03 00:37:43 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Richard W.M. Jones 2014-11-18 06:27:15 EST
Virt-v2v needs to run on the latest Red Hat Enterprise Linux release
to ensure it can correctly read and modify new guest filesystem
features.  A new version of virt-v2v is now available for RHEL 7.1.

Before RHEL 7.1 is released, follow the instructions here to
install unsupported preview packages on top of RHEL 7.0:
https://www.redhat.com/archives/libguestfs/2014-May/msg00090.html

After RHEL 7.1 is released, virt-v2v will be available in
Technical Preview.

You can run virt-v2v in a single virtual machine.  Other
requirements are covered here:
http://libguestfs.org/virt-v2v.1.html#resource-requirements

If you find a missing feature or bug in the new version of virt-v2v
please file a bug using the following link:
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%207&component=libguestfs

Note You need to log in before you can comment on or make changes to this bug.