Bug 803572 - RFE: Support Plural forms in Zanata
Summary: RFE: Support Plural forms in Zanata
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-Persistence, Component-UI, Component-PythonClient, Usability, DatabaseChange (Show other bugs)
(Show other bugs)
Version: 1.5
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.6-alpha-1
Assignee: Alex Eng
QA Contact: Joyce Chang
URL:
Whiteboard:
Keywords: UserStory
Depends On: 814006
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-15 05:30 UTC by Alex Eng
Modified: 2013-03-04 03:19 UTC (History)
6 users (show)

Fixed In Version: Zanata version 1.6.0-beta-2-SNAPSHOT (20120523-0019).
Doc Type: Bug Fix
Doc Text:
Cause In translation files, msg_plural entries provide multiple versions of a noun string. These entries allows software to present the correct singular or plural version of the noun to match a number in a message. Zanata did not support msg_plural entries. Consequence Zanata silently ignored msg_plural entries in POT/PO files Change Plural support was added to Zanata's data model, database schema, REST API model, Maven/Python clients, webtrans editor UI and translation memory search feature. Result Plurals are now accepted/returned via REST clients, accepted/displayed in the editor UI and in TM search results
Story Points: 13
Clone Of:
Environment:
Last Closed: 2012-06-22 00:58:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Eng 2012-03-15 05:30:20 UTC
Introduce support for plural forms.


1) Client support plural when push documents.
2) Translation editor supports of plural entry.

Comment 1 David Mason 2012-03-16 06:39:03 UTC
Current behaviour of python client:

pushing source with plural forms: pushes msgid and ignores msgid_plural.

pushing translations with plural forms: does not push translations for plural forms (probably because "msgstr" is not present, only "msgstr[0], msgstr[1], etc.). Translations for surrounding text flows are pushed correctly.

Comment 2 Joshua Wulf 2012-04-17 05:23:47 UTC
Please see: https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

I've filled in the Technical Notes field with the information that I have to hand. Could you please verify / correct what's there, and provide what's missing?

Comment 3 Joshua Wulf 2012-04-17 05:23:47 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
In translation files, msg_plural entries provide multiple versions of a noun string. These entries allows software to present the correct singular or plural version of the noun to match a number in a message. Zanata did not support msg_plural entries (?).

Consequence
Zanata (???did not handle?????crashed when encountering???ignored???) files containing msg_plural entries

Change
What was done to implement the feature.
Note: backported from upstream is not an explanation.

Result
What now happens when the actions or circumstances above occur.
Note: this is not the same as the feature request was fulfilled.

Comment 4 Sean Flanigan 2012-04-17 05:55:06 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,13 +1,11 @@
 Cause
-In translation files, msg_plural entries provide multiple versions of a noun string. These entries allows software to present the correct singular or plural version of the noun to match a number in a message. Zanata did not support msg_plural entries (?).
+In translation files, msg_plural entries provide multiple versions of a noun string. These entries allows software to present the correct singular or plural version of the noun to match a number in a message. Zanata did not support msg_plural entries.
 
 Consequence
-Zanata (???did not handle?????crashed when encountering???ignored???) files containing msg_plural entries
+Zanata silently ignored msg_plural entries in POT/PO files
 
 Change
-What was done to implement the feature.
-Note: backported from upstream is not an explanation.
+Plural support was added to Zanata's data model, database schema, REST API model, Maven/Python clients, webtrans editor UI and translation memory search feature.
 
 Result
-What now happens when the actions or circumstances above occur.
+Plurals are now accepted/returned via REST clients, accepted/displayed in the editor UI and in TM search results-Note: this is not the same as the feature request was fulfilled.

Comment 5 Joyce Chang 2012-05-03 05:20:03 UTC
verified in Zanata version 1.6.0-alpha-3-SNAPSHOT (20120430-0019).

Comment 6 Sean Flanigan 2012-05-04 00:36:54 UTC
Actually, this should still be in MODIFIED state due to bug 814006.

Comment 7 Joyce Chang 2012-05-04 01:27:21 UTC
oops,thanks for reminding!!

Comment 8 Joyce Chang 2012-05-23 01:23:46 UTC
verified in Zanata version 1.6.0-beta-2-SNAPSHOT (20120523-0019).


Note You need to log in before you can comment on or make changes to this bug.