Bug 803651 - Not clear description for using rhc-ctl-domain to updating not existing key
Not clear description for using rhc-ctl-domain to updating not existing key
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 07:09 EDT by bzhao
Modified: 2015-05-14 21:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:34:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bzhao 2012-03-15 07:09:44 EDT
Description of problem:
It will prompt "Unable to read user public keyfile XX.pub" while you executed rhc-ctl-domain to updating an not existed key


Version-Release number of selected component (if applicable):
rhc-0.88.4-1.el6_2.noarch

How reproducible:
Always

Steps to Reproduce:
1.Call CLI to update a ssh key with no existing specific key-name
# rhc-ctl-domain --update-ssh-key XXX -k XXX.pub -p XXX

  
Actual results:
It will return "Unable to read user public keyfile XXX.pub"

Expected results:
It should prompt "Key name 'XXX' doesn't exist for user XXX"

Additional info:
Comment 1 John (J5) Palmieri 2012-04-09 14:33:44 EDT
The error is triggered because the key file XXX.pub can not be read.  It doesn't even get to the point of querying the server for an existing key.  Does this happen if you give it a valid key file but non extant key name?  Otherwise the error is correct.
Comment 2 bzhao 2012-04-10 02:35:49 EDT
Passed verification againt devenv_1704

Note You need to log in before you can comment on or make changes to this bug.