Bug 803654 - Videos in express and flex page can not play on Firefox and IE
Videos in express and flex page can not play on Firefox and IE
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 07:14 EDT by Xiaoli Tian
Modified: 2015-05-14 21:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhc-site-0.89.1-1+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:34:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Videos page in IE (6.43 KB, image/png)
2012-03-15 07:14 EDT, Xiaoli Tian
no flags Details
Video in Tudou in Old site (44.74 KB, image/png)
2012-03-16 22:50 EDT, Xiaoli Tian
no flags Details
video code in devenv-stage_146 (19.04 KB, image/png)
2012-03-19 05:00 EDT, Xiaoli Tian
no flags Details
video code in production (18.57 KB, image/png)
2012-03-19 05:01 EDT, Xiaoli Tian
no flags Details
Some error in firebug (34.33 KB, image/png)
2012-03-19 05:02 EDT, Xiaoli Tian
no flags Details

  None (edit)
Description Xiaoli Tian 2012-03-15 07:14:09 EDT
Description of problem:
Videos in /app/express and /app/flex can not play on firefox (tried on firefox 3.6,firefox10) and IE(IE8,IE9),btw it could play on chrome.


Version-Release number of selected component (if applicable):
rhc-site-0.88.10-1.el6_2.noarch
devenv_1622
firefox 3.6,firefox 10
IE8, IE9

How reproducible:
Always

Steps to Reproduce:
1.Try to play videos in /app/express and /app/flex in the new site via firefox or chrome.
  
Actual results:
Can not play ,see attachment

Expected results:
It could play on IE and firefox

Additional info:
Comment 1 Xiaoli Tian 2012-03-15 07:14:38 EDT
Created attachment 570257 [details]
Videos page in IE
Comment 2 Fabiano Franz 2012-03-15 14:28:05 EDT
Fixed, tested on IE8 and FF10 on Windows XP and FF10 on Fedora 16. Thanks.
Comment 3 Yujie Zhang 2012-03-16 00:44:32 EDT
Still has this problem on devenv-stage_144.
Comment 4 Xiaoli Tian 2012-03-16 00:59:19 EDT
Hi,Fabiano :

Maybe your fix is not built in devenv-stage_144.
Comment 5 Xiaoli Tian 2012-03-16 01:29:54 EDT
Hi,Fabiano

I think you fix part of it, this bug is also a little related to bug 711943 .

1. After your fix, we  could play the video (which is in youtube) in china if we set browser proxy now via IE and Firefox.

2. But if we do not set proxy , we could not even see the videos image and can not play the videos in China in IE and firefox, but it's strange that we could 
play the videos in Chrome even without proxy.

Other information:

If set proxy, then the video src is : src="//www.youtube.com/embed/KLtbuvyJFFE?wmode=transparent&rel=0"

If not set proxy, that's to say we access from china absolutely , the video related parameters are like :
<param value="http://www.tudou.com/v/bV4wk9cW_Tw" name="movie">
<param value="true" name="allowFullScreen">
<param value="transparent" name="wmode">

Thanks
Comment 6 Fabiano Franz 2012-03-16 21:10:45 EDT
Thanks for the additional info.
Could you please confirm if the previous version of Express and Flex pages (which contains the same videos) are working, or have the same issue? The embedding code is pretty much the same for new and previous versions:

https://openshift.redhat.com/app/express
https://openshift.redhat.com/app/flex

Thanks!
Comment 7 Xiaoli Tian 2012-03-16 22:50:25 EDT
Created attachment 570746 [details]
Video in Tudou in Old site

Hi, Fabiano

I'm sure it works in the old site if access it directly without proxy from China.

Attached is the screenshot.


Thanks for digging more.
Comment 8 Xiaoli Tian 2012-03-19 04:07:30 EDT
Hi,Fabiano


Yeah, comparing site in devenv-stage_145 with production, there's not much difference, attached are screenshots of  parameters in devenv-stage_146 and production, hope if it helps you to debug.



To Clayton, since this  bug will only affect user who use Firefox and IE in China, if all of you think it's not high priority or not a blocker for release, please feel free to lower its priority.
Comment 9 Xiaoli Tian 2012-03-19 05:00:50 EDT
Created attachment 571060 [details]
video code in devenv-stage_146
Comment 10 Xiaoli Tian 2012-03-19 05:01:51 EDT
Created attachment 571061 [details]
video code in production
Comment 11 Xiaoli Tian 2012-03-19 05:02:32 EDT
Created attachment 571062 [details]
Some error in firebug
Comment 12 Fabiano Franz 2012-03-19 09:25:07 EDT
> To Clayton, since this  bug will only affect user who use Firefox and IE in
> China, if all of you think it's not high priority or not a blocker for release,
> please feel free to lower its priority.

Agree it's not high priority, lowering. (In reply to comment #8)
Comment 13 Clayton Coleman 2012-03-19 11:54:33 EDT
We should fix this in sprint 8 - need to get back to working on this.
Comment 14 Fabiano Franz 2012-03-21 16:50:56 EDT
Fixed since the /app/express and /app/flex pages are no longer available. The videos are now only linked inside /app/getting_started (no more embedding).
Comment 15 Yujie Zhang 2012-03-23 02:42:47 EDT
Verify this bug since the /app/express and /app/flex pages are removed.

Note You need to log in before you can comment on or make changes to this bug.