Bug 803706 - Mouse cursor stuck in corners when using multiple displays
Mouse cursor stuck in corners when using multiple displays
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 09:21 EDT by Tomas Jamrisko
Modified: 2012-03-28 14:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-28 14:59:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screen layout (3.90 KB, image/png)
2012-03-28 09:54 EDT, Tomas Jamrisko
no flags Details

  None (edit)
Description Tomas Jamrisko 2012-03-15 09:21:00 EDT
Description of problem:
Cursor gets stuck in corners of the smaller screen, partially visible on the larger instead of going all the way through. 


Version-Release number of selected component (if applicable):
gnome-shell-3.3.90-2

How reproducible:
always

Steps to Reproduce:
1. Setup two screens (gnome-shell should run on the smaller one)
2. Try to move your mouse along either top or bottom edge to get to the larger monitor 
  
Actual results:
Pointer becomes partially visible on the larger screen and for some reason gets stuck there, even though there is no visible boundary

Expected results:
Pointer moves
Comment 1 Owen Taylor 2012-03-27 13:23:34 EDT
The presence of "pointer barriers" at the screen corners is intentional, but they are only supposed to be there when there's a "hot corner" at that corner. So, if your mouse pointer is getting stuck on a corner, but nothing happens there, that would be a bug.

Can you give more detail about how your monitors are aligned vertically and which monitor is on the right and on the left?
Comment 2 Tomas Jamrisko 2012-03-28 09:54:56 EDT
Created attachment 573356 [details]
Screen layout

This attachment shows the alignment of screens I used when reporting the bug. Resolutions were 1440x900 and 1920x1080, primary screen (with the shell) was the smaller one on the left.

If you can't reproduce it, I'll give it another shot tomorrow (not it fedora right now) and report back the results
Comment 3 Owen Taylor 2012-03-28 14:59:43 EDT
Tested with this and other layouts, and the behavior I observed was:

 * Pointer barriers are installed:
    - At the upper left of the primary monitor, for the hot corner there
    - At the upper right of the primary monitor, to make the user menu easily accessible
    - At the lower right of the primary monitor, for the hot corner there

 * Hot corners to activate the overview are present
    - At the upper left of the primary monitor
    - At the upper left of the screen if that's not the same as the upper left of the primary monitor

This corresponds to the code and I believe is as intended in the design. I did discover bugs:
 
  https://bugs.freedesktop.org/show_bug.cgi?id=48008
  https://bugzilla.gnome.org/show_bug.cgi?id=673018

(So thanks for inspiring me to test/look at the code!)

But I don't think either of these is related to what you observing - most likely you were observing things behaving as intended. So, I'm going to close this as NOTABUG. If you observe behavior differing from what I've described above feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.