Bug 803736 - pkg-config --cflags libreport includs -fPIC
pkg-config --cflags libreport includs -fPIC
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 10:30 EDT by Jerry James
Modified: 2014-02-02 17:16 EST (History)
10 users (show)

See Also:
Fixed In Version: abrt-2.0.10-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 19:00:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2012-03-15 10:30:25 EDT
Description of problem:
I'm developing a libreport plugin for my employer, to facilitate internal crash reporting for locally developed applications.  Using pkgconfig resulted in -fPIC in the CFLAGS of the executables.  This is because "pkg-config --cflags libreport" includes -fPIC.  It shouldn't.  That flag is needed only if the consumer is building a library, which I am not.

Version-Release number of selected component (if applicable):
libreport-devel-2.0.8-6.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. pkg-config --cflags libreport
2.
3.
  
Actual results:
The result contains -fPIC.

Expected results:
I should specify -fPIC myself if I am building a library, and not if I am building an executable; pkg-config shouldn't force me to use it in all cases.

Additional info:
Comment 1 Nikola Pajkovsky 2012-03-15 11:08:26 EDT
commit 0bc8469662ba6742e4a01bcfb2245b06332231bc
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Thu Mar 15 16:09:17 2012 +0100

    libreport.pc: rhbz#803736 - pkg-config --cflags libreport includs -fPIC
    
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>
Comment 2 Fedora Update System 2012-03-27 06:18:21 EDT
abrt-2.0.9-1.fc17, libreport-2.0.10-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.9-1.fc17,libreport-2.0.10-1.fc17
Comment 3 Fedora Update System 2012-03-28 01:59:11 EDT
Package abrt-2.0.9-1.fc17, libreport-2.0.10-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.9-1.fc17 libreport-2.0.10-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4804/abrt-2.0.9-1.fc17,libreport-2.0.10-1.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-04-02 09:34:18 EDT
abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17
Comment 5 Fedora Update System 2012-04-18 19:00:13 EDT
abrt-2.0.10-1.fc17, libreport-2.0.10-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.