Bug 803738 - APC problem with PHP 5.4
APC problem with PHP 5.4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-pecl-apc (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 10:31 EDT by Michał Piotrowski
Modified: 2012-04-11 21:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: php-pecl-apc-3.1.9-6.svn324146.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 21:57:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michał Piotrowski 2012-03-15 10:31:53 EDT
Description of problem:
There is a problem with actual APC version and PHP 5.4. When I first time open a page created with Symfony2 everything works fine, but when I reload page in browser I get white screen. The reason for such malfunction is bug in APC - it has been fixed in one of the last SVN version. Please update php-pecl-apc to latest SVN version.

Described problem can be recreated on Symfony2 sandbox
http://symfony.com/download?v=Symfony_Standard_Vendors_2.0.11.tgz

Best regards,
Michal


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Remi Collet 2012-03-15 11:53:09 EDT
This bug is fixed by upstream.
I will push an update to 324146 asap

Can you please try this "test" build
http://rpms.famillecollet.com/fedora/17/remi/x86_64/repoview/php-pecl-apc.html
or 
http://rpms.famillecollet.com/fedora/17/remi/i386/repoview/php-pecl-apc.html
Comment 2 Fedora Update System 2012-03-15 14:35:11 EDT
php-pecl-apc-3.1.9-6.svn324146.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/php-pecl-apc-3.1.9-6.svn324146.fc17
Comment 3 Michał Piotrowski 2012-03-15 14:40:49 EDT
(In reply to comment #1)
> This bug is fixed by upstream.
> I will push an update to 324146 asap
> 
> Can you please try this "test" build
> http://rpms.famillecollet.com/fedora/17/remi/x86_64/repoview/php-pecl-apc.html

I tested php-pecl-apc-3.1.9-7.svn324146.fc17.remi.x86_64.rpm package and I confirm that problem is fixed. Thank you very much!
Comment 4 Fedora Update System 2012-03-15 22:45:40 EDT
Package php-pecl-apc-3.1.9-6.svn324146.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-pecl-apc-3.1.9-6.svn324146.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3902/php-pecl-apc-3.1.9-6.svn324146.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-04-11 21:57:14 EDT
php-pecl-apc-3.1.9-6.svn324146.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.