Bug 803759 - crash when scanning
crash when scanning
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 11:24 EDT by Nathaniel McCallum
Modified: 2013-02-13 18:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 18:52:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Quick patch that revert broken changes (3.29 KB, patch)
2012-06-20 18:20 EDT, Nicolas Dufresne
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1020049 None None None 2012-07-02 07:24:26 EDT

  None (edit)
Description Nathaniel McCallum 2012-03-15 11:24:24 EDT
1. Open simple-scan.
2. Click scan
3. Crash (everytime)

#0  0x00007fffd46627e6 in soapht_control_option (handle=0x7fffdc06f890, option=4, action=
    SANE_ACTION_SET_VALUE, value=0x7fffdc0919d0, set_result=0x0) at scan/sane/soapht.c:668
#1  0x00007fffd4659ff6 in sane_hpaio_control_option (handle=0x7fffdc06f890, option=4, action=
    SANE_ACTION_SET_VALUE, pValue=0x7fffdc0919d0, pInfo=<optimized out>) at scan/sane/hpaio.c:2487
#2  0x000000000041b6f3 in scanner_set_string_option (self=<optimized out>, handle=0x7fffdc144bb0, option=
    0x7fffdc06fbb8, option_index=4, value=0x7fffdc146570 "Flatbed", _result_=0x7fffea418b38)
    at scanner.c:4263
#3  0x000000000041beba in scanner_set_constrained_string_option (self=, handle=0x7fffdc144bb0, option=
    0x7fffdc06fbb8, option_index=4, values=0x7fffdc147400, values_length1=<optimized out>, _result_=0x0)
    at scanner.c:4406
#4  0x000000000042332e in scanner_do_get_option (self=<optimized out>) at scanner.c:5982
#5  scanner_scan_thread (self=<optimized out>) at scanner.c:7635
#6  _scanner_scan_thread_gthread_func (self=<optimized out>) at scanner.c:7664
#7  0x0000003ec0c697f5 in ?? () from /usr/lib64/libglib-2.0.so.0
#8  0x0000003ebf007d90 in start_thread (arg=0x7fffea419700) at pthread_create.c:309
#9  0x0000003ebecf0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
Comment 1 Nathaniel McCallum 2012-03-15 11:33:42 EDT
3.11.12-2 works fine
Comment 2 Jiri Popelka 2012-03-15 11:36:24 EDT
And with what version do you see the crashes ?
Comment 3 Nathaniel McCallum 2012-03-15 12:28:13 EDT
hplip-3.12.2-3.fc16
Comment 4 Tim Waugh 2012-04-02 11:16:00 EDT
That's weird. That version is effectively just a rebuild with no code changes.

Can you run 'info locals' in gdb at the point where you get the backtrace?  It would also be useful to see the full gdb output -- for example, what signal was received?
Comment 5 Nicolas Dufresne 2012-06-20 17:19:20 EDT
Same crash here, Fedora 17. Debug info is missing for the affected package, no locals, sorry.

Affected:
libsane-hpaio-3.12.6-1.fc17.x86_64



Backtrace:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffe9b72700 (LWP 25673)]
0x00007fffd3a2a6be in soapht_control_option () from /usr/lib64/sane/libsane-hpaio.so.1
(gdb) bt
#0  0x00007fffd3a2a6be in soapht_control_option () from /usr/lib64/sane/libsane-hpaio.so.1
#1  0x00007fffd3a22246 in sane_hpaio_control_option () from /usr/lib64/sane/libsane-hpaio.so.1
#2  0x000000000041c62f in ?? ()
#3  0x000000000041cea5 in ?? ()
#4  0x0000000000423ad6 in ?? ()
#5  0x0000003fee46a345 in g_thread_proxy (data=0x67bca0) at gthread.c:801
#6  0x0000003388207d14 in start_thread (arg=0x7fffe9b72700) at pthread_create.c:309
#7  0x0000003387ef199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
Comment 6 Nicolas Dufresne 2012-06-20 18:20:39 EDT
Created attachment 593318 [details]
Quick patch that revert broken changes

I reverted some obscure changes to it's state as found in 3.11 and now it works.
Comment 7 Jiri Popelka 2012-07-02 06:26:23 EDT
(In reply to comment #5)
> Debug info is missing for the affected package, no locals, sorry.

Can you install it with:
yum --enablerepo=updates-testing install hplip-debuginfo
and try to get the backtrace again ?
Comment 8 Jiri Popelka 2012-07-02 06:53:39 EDT
I've searched simple-scan BZs and found bug #801145 where's a good backtrace.

bug #801145, comment #4 states that "Reinstalling hplip's plugin with hp-setup helped."
Comment 9 Nicolas Dufresne 2012-10-15 12:07:16 EDT
Any reason to ignore the proposed patch ? As been working fine for me for a long time now.
Comment 10 Jiri Popelka 2012-10-15 13:26:35 EDT
Although we really appreciate a patch along with a bug report, we need a patch that fixes the problem where it is so we can try to push it upstream (HP). In this case the patch is a work-around and most likely will be refused by upstream. And to create proper patch we need sufficient debuginfo first.

Have you already tried to update the hp-plugin ?
Comment 11 Nicolas Dufresne 2012-10-15 14:09:37 EDT
You need to understand this is a patch being revert, not a workaround. Telling upstream they have a patch to blame would most likely be a good step forward. But meanwhile, improving usability for your users would also be great.
Comment 12 Fedora End Of Life 2013-01-16 15:28:28 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Fedora End Of Life 2013-02-13 18:52:24 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.