Bug 803765 - rpm verify - changed order of verify attributes
rpm verify - changed order of verify attributes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm (Show other bugs)
7.0
All Linux
low Severity low
: beta
: ---
Assigned To: Panu Matilainen
Hubert Kario
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 11:38 EDT by Miroslav Vadkerti
Modified: 2014-06-13 07:20 EDT (History)
1 user (show)

See Also:
Fixed In Version: rpm-4.10.0-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:20:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Vadkerti 2012-03-15 11:38:43 EDT
Description of problem:
The order of the verify attributes has changed and id now doesn't match the order in the man page:

       S file Size differs
       M Mode differs (includes permissions and file type)
       5 MD5 sum differs
       D Device major/minor number mismatch
       L readLink(2) path mismatch
       U User ownership differs
       G Group ownership differs
       T mTime differs
       P caPabilities differ

RHEL7:
5..T.....    /usr/share/test/content
......G..    /usr/share/test/group
.......M.    /usr/share/test/permissions
5S.T.....    /usr/share/test/size
...T.....    /usr/share/test/time
.....U...    /usr/share/test/user

RHEL6:
..5....T.    /usr/share/test/content
......G..    /usr/share/test/group
.M.......    /usr/share/test/permissions
S.5....T.    /usr/share/test/size
.......T.    /usr/share/test/time
.....U...    /usr/share/test/user

Version-Release number of selected component (if applicable):
rpm-4.9.1.2-1.el7

How reproducible:
100%

Steps to Reproduce:
1. rpm -Va
  
Actual results:
Order doesn't match man page desc

Expected results:
Order matches man page desc

Additional info:
Comment 1 Panu Matilainen 2012-03-16 00:49:32 EDT
Yup, see bug 797964 for the Fedora counterpart.
Comment 3 Panu Matilainen 2012-08-14 02:35:10 EDT
Since Alpha-2, RHEL-7 rpm has been rebased to version 4.10 where this was fixed upstream.
Comment 5 Ludek Smid 2014-06-13 07:20:19 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.