Bug 803777 - Add a connection dialog to remote-viewer when no URI is provided on the command line
Add a connection dialog to remote-viewer when no URI is provided on the comma...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-viewer (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 11:55 EDT by Christophe Fergeau
Modified: 2012-05-26 04:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 04:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christophe Fergeau 2012-03-15 11:55:01 EDT
spicy pops up a very simple dialog where one can enter connection information when the user did not specify where to connect to on the command line. It would be nice to get something similar in remote-viewer when no URL was provided.
Comment 1 Daniel Berrange 2012-04-18 08:18:31 EDT
Done upstream

commit 7d3dbb57b05b3b0d66e9540220ef84291d44d833
Author: Marc-André Lureau <marcandre.lureau@gmail.com>
Date:   Wed Mar 28 18:45:40 2012 +0200

    remote-viewer: add a simple connection dialog
    
    If the user doesn't provide URI, let's show a simple dialog to enter it.
    
    Also save & list recently used URLs in that dialog.

Will be in next release
Comment 2 Marc-Andre Lureau 2012-04-18 14:23:41 EDT
Daniel, should the state be changed to modified?
Comment 3 Daniel Berrange 2012-04-18 14:50:00 EDT
Not until the release is actally built in Fedora
Comment 4 Fedora Update System 2012-05-16 08:35:21 EDT
virt-viewer-0.5.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-viewer-0.5.3-1.fc17
Comment 5 Scott Dowdle 2012-05-16 13:07:19 EDT
Any way we could get another featured added to the Windows build?  It would be nice if spice:// URLs were registered as a mimetype with Windows so clicking on a spice:// link in Firefox and/or MSIE would pass it on to remote-viewer.exe.  This seems to be the way to do it:

spice.reg sample:
----------
REGEDIT4

[HKEY_CLASSES_ROOT\spice]
@="URL:spice Protocol"
"URL Protocol"=""

[HKEY_CLASSES_ROOT\spice\shell]

[HKEY_CLASSES_ROOT\spice\shell\open]

[HKEY_CLASSES_ROOT\spice\shell\open\command]
@="\"C:\\Program Files\\virt-viewer\\bin\\remote-viewer.exe\" \"%1\"" 
----------

I'm not a Windows guru so there is probably a better way to do it... but if the virt-viewer-0.5.3.exe (or later versions) installer would register spice:// URLs it sure would save people a lot of headache figuring it out for themselves.
Comment 6 Fedora Update System 2012-05-26 04:04:39 EDT
virt-viewer-0.5.3-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.