Bug 803790 - remote-viewer chokes on trailing slash in URLs
remote-viewer chokes on trailing slash in URLs
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: spice-gtk (Show other bugs)
17
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Marc-Andre Lureau
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 12:24 EDT by Marko Myllynen
Modified: 2012-10-21 18:44 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-21 18:44:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2012-03-15 12:24:31 EDT
Description of problem:
A tiny usability issue:

remote-viewer spice://192.168.1.1:5901  works ok
remote-viewer spice://192.168.1.1:5901/ fails, saying can't connect the server

I noticed this when testing spice:// access with Firefox where it is common to have trailing slashes in URLs (see bug 798185).
Comment 1 Daniel Berrange 2012-04-19 10:57:50 EDT
Turns out to be a SPICE uri parsing bug, fixed in this patch

http://lists.freedesktop.org/archives/spice-devel/2012-April/008808.html
Comment 2 Daniel Berrange 2012-04-24 05:55:43 EDT
Fixed upstream in

commit 50add15ef69cde34346e11b5c91e1257cecb2696
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Thu Apr 19 11:12:09 2012 +0100

    Fix multiple problems with URI parsing
Comment 3 Cole Robinson 2012-10-21 18:44:37 EDT
Just closing as UPSTREAM given lack of other noise about this.

Note You need to log in before you can comment on or make changes to this bug.