Bug 803844 - inadyn.service timeouts
inadyn.service timeouts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: inadyn-mt (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 14:31 EDT by cornel panceac
Modified: 2012-06-02 11:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 03:27:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2012-03-15 14:31:23 EDT
Description of problem:
looking at the status of inadyn.service i've seen it's failed although the main process exited with success:

$ systemctl status inadyn.service
inadyn.service - Inadyn-mt, register an IP Address to a dynamic DNS provider
	  Loaded: loaded (/lib/systemd/system/inadyn.service; enabled)
	  Active: failed since Thu, 15 Mar 2012 19:33:21 +0200; 26min ago
	 Process: 889 ExecStart=/usr/sbin/inadyn (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/inadyn.service



Version-Release number of selected component (if applicable):

$ rpm -qf /usr/sbin/inadyn 
inadyn-mt-2.24.36-1.fc16.i686


How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
service should not be failed when the exit status is success.

Additional info:
i've changed type to simple and started the service. again it failed after timeout. 

type oneshot was the right one, it seems: the systemctl start completed immediately and exit status was success.
Comment 1 Fedora Update System 2012-04-25 15:56:31 EDT
inadyn-mt-2.24.36-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/inadyn-mt-2.24.36-1.fc17
Comment 2 Fedora Update System 2012-04-26 15:27:18 EDT
Package inadyn-mt-2.24.36-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing inadyn-mt-2.24.36-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6664/inadyn-mt-2.24.36-1.fc17
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-05-08 14:50:16 EDT
inadyn-mt-2.24.36-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/inadyn-mt-2.24.36-3.fc17
Comment 4 Daniel Wang 2012-05-10 18:17:44 EDT
Thanks! I've tried package inadyn-mt-2.24.36-1.fc17 , and "oneshot" certainly yields a "SUCCESS" status, but inadyn is reported dead by "systemctl status inadyn.service". "ps -ef | grep inadyn" confirms this.  

inadyn is designed to run in the background. I tried restoring the original "Type=forking" but without specifying the pid file, and things seem to work better--inadyn continues running, systemctl reports that it is active, with the proper PID, and start/stop/restart commands seem to work, despite leaving out a PIDfile spec.

I recommend switching back to Type=forking, but without any specification of pidfile (despite the manpage's recommendation), since systemd seems to be able to determine the pid on its own.
Comment 5 Fedora Update System 2012-05-26 03:27:18 EDT
inadyn-mt-2.24.36-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Bryan Hoover 2012-06-02 11:21:05 EDT
(In reply to comment #4)

Regarding the comment, "designed to run in background," run in background requires the --background command.  Problem may be use of this command without need for it when running as a function of the Fedora service infrastructure.  Old, previously set up versions of inadyn-mt may contain configuration files with this background command.

This may be the problem.  So changing the service type may have been unecessary -- instead, remove background command.  Dunno.  Can't test at the moment, but I seem to remember similar experience with past testing, other Fedora versions, and service infrastructure.  Hope this helps.

Regards,
Bryan
> Thanks! I've tried package inadyn-mt-2.24.36-1.fc17 , and "oneshot"
> certainly yields a "SUCCESS" status, but inadyn is reported dead by
> "systemctl status inadyn.service". "ps -ef | grep inadyn" confirms this.  
> inadyn is designed to run in the background. I tried restoring the original
> "Type=forking" but without specifying the pid file, and things seem to work
> better--inadyn continues running, systemctl reports that it is active, with
> the proper PID, and start/stop/restart commands seem to work, despite
> leaving out a PIDfile spec.

I recommend switching back to Type=forking, but
> without any specification of pidfile (despite the manpage's recommendation),
> since systemd seems to be able to determine the pid on its own.

Note You need to log in before you can comment on or make changes to this bug.