Bug 803898 - Fedora uses both video cards on switchable graphics system
Fedora uses both video cards on switchable graphics system
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 17:39 EDT by Daniel Mircea
Modified: 2012-03-22 14:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-22 14:58:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Mircea 2012-03-15 17:39:57 EDT
My notebook (http://www.smolts.org/client/show/pub_b6d604da-b141-4922-b29c-498110fa4d2b) has two video cards, switchable by an actual hardware button (with no way of disabling any of them from the BIOS).

Both of the cards are running at the same time when using fedora. You can easily tell by the heat, fan noise and the extremely poor battery life.

I disabled one of the cards by using vga swticheroo (at each boot), but I really think that this should be fixed by default.

I also booted the latest fedora 17 image (https://fedoraproject.org/wiki/Test_Day:2012-03-15_Gnome_Shell_and_Extensions), but couldn't use more than a few minutes, being afraid that it will damage my machine.

This issue is really serious.
Comment 1 Josh Boyer 2012-03-16 07:06:05 EDT
Dave, if vga_switcheroo works in this case is there a way to disable one by default?
Comment 2 Dave Jones 2012-03-22 12:56:31 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 3 Dave Jones 2012-03-22 13:00:17 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Dave Jones 2012-03-22 13:11:34 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Daniel Mircea 2012-03-22 14:51:17 EDT
Please close the ticket. 

Looks like the problem was fixed after the last kernel update.

Note You need to log in before you can comment on or make changes to this bug.