This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 803986 - ksh hangs
ksh hangs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ksh (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michal Hlavinka
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 04:27 EDT by Michal Hlavinka
Modified: 2014-06-16 04:18 EDT (History)
0 users

See Also:
Fixed In Version: ksh-20120229-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-16 04:18:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix this (793 bytes, patch)
2012-03-19 07:18 EDT, Michal Hlavinka
no flags Details | Diff

  None (edit)
Description Michal Hlavinka 2012-03-16 04:27:04 EDT
Description of problem:
there is bug in 2012-01-01+ ksh hangs when application does some dark magic with file descriptors


How reproducible:
always

Steps to Reproduce:
(set some nice memory ulimit, it eats memory quite fast)
ksh -c 'latestver() { rpmdev-vercmp 1 2 >/dev/null; } ; echo $(latestver)'
  
Actual results:
hangs


Expected results:
pass (no output)

Additional info:
rpm* python scripts do something weird with file descriptors, but ksh still should not hang. I was not able to reproduce this with anything different than rpm* python things.
Comment 1 Michal Hlavinka 2012-03-19 07:17:31 EDT
fixed in ksh-20120229-2.fc17
Comment 2 Michal Hlavinka 2012-03-19 07:18:18 EDT
Created attachment 571091 [details]
patch to fix this
Comment 4 Ludek Smid 2014-06-16 04:18:56 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.