Bug 804041 - Pollutes /usr/lib/python2.7/site-packages/tests with its test suite
Pollutes /usr/lib/python2.7/site-packages/tests with its test suite
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-boto (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 07:40 EDT by Daniel Berrange
Modified: 2012-05-02 00:53 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-boto-2.3.0-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 00:53:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2012-03-16 07:40:04 EDT
Description of problem:
These private unit tests should not be installed in the RPM, not least because
they clash with other (bogusly installed) test files from python-past-script. This
prevents installation of openstack in Fedora 17 updates-testing


# rpm -ql python-boto | grep /usr/lib/python2.7/site-packages/tests 
/usr/lib/python2.7/site-packages/tests
/usr/lib/python2.7/site-packages/tests/__init__.py
/usr/lib/python2.7/site-packages/tests/__init__.pyc
/usr/lib/python2.7/site-packages/tests/__init__.pyo
/usr/lib/python2.7/site-packages/tests/autoscale
/usr/lib/python2.7/site-packages/tests/autoscale/__init__.py
/usr/lib/python2.7/site-packages/tests/autoscale/__init__.pyc
/usr/lib/python2.7/site-packages/tests/autoscale/__init__.pyo
/usr/lib/python2.7/site-packages/tests/autoscale/test_connection.py
/usr/lib/python2.7/site-packages/tests/autoscale/test_connection.pyc
/usr/lib/python2.7/site-packages/tests/autoscale/test_connection.pyo
/usr/lib/python2.7/site-packages/tests/cloudfront
/usr/lib/python2.7/site-packages/tests/cloudfront/__init__.py
/usr/lib/python2.7/site-packages/tests/cloudfront/__init__.pyc
/usr/lib/python2.7/site-packages/tests/cloudfront/__init__.pyo
/usr/lib/python2.7/site-packages/tests/cloudfront/test_signed_urls.py
/usr/lib/python2.7/site-packages/tests/cloudfront/test_signed_urls.pyc
/usr/lib/python2.7/site-packages/tests/cloudfront/test_signed_urls.pyo
/usr/lib/python2.7/site-packages/tests/db
/usr/lib/python2.7/site-packages/tests/db/test_lists.py
/usr/lib/python2.7/site-packages/tests/db/test_lists.pyc
/usr/lib/python2.7/site-packages/tests/db/test_lists.pyo
/usr/lib/python2.7/site-packages/tests/db/test_password.py
/usr/lib/python2.7/site-packages/tests/db/test_password.pyc
/usr/lib/python2.7/site-packages/tests/db/test_password.pyo
/usr/lib/python2.7/site-packages/tests/db/test_query.py
/usr/lib/python2.7/site-packages/tests/db/test_query.pyc
/usr/lib/python2.7/site-packages/tests/db/test_query.pyo
/usr/lib/python2.7/site-packages/tests/db/test_sequence.py
/usr/lib/python2.7/site-packages/tests/db/test_sequence.pyc
/usr/lib/python2.7/site-packages/tests/db/test_sequence.pyo
/usr/lib/python2.7/site-packages/tests/devpay
/usr/lib/python2.7/site-packages/tests/devpay/__init__.py
/usr/lib/python2.7/site-packages/tests/devpay/__init__.pyc
/usr/lib/python2.7/site-packages/tests/devpay/__init__.pyo
/usr/lib/python2.7/site-packages/tests/devpay/test_s3.py
/usr/lib/python2.7/site-packages/tests/devpay/test_s3.pyc
/usr/lib/python2.7/site-packages/tests/devpay/test_s3.pyo
/usr/lib/python2.7/site-packages/tests/dynamodb
/usr/lib/python2.7/site-packages/tests/dynamodb/__init__.py
/usr/lib/python2.7/site-packages/tests/dynamodb/__init__.pyc
/usr/lib/python2.7/site-packages/tests/dynamodb/__init__.pyo
/usr/lib/python2.7/site-packages/tests/dynamodb/test_layer1.py
/usr/lib/python2.7/site-packages/tests/dynamodb/test_layer1.pyc
/usr/lib/python2.7/site-packages/tests/dynamodb/test_layer1.pyo
/usr/lib/python2.7/site-packages/tests/dynamodb/test_layer2.py
/usr/lib/python2.7/site-packages/tests/dynamodb/test_layer2.pyc
/usr/lib/python2.7/site-packages/tests/dynamodb/test_layer2.pyo
/usr/lib/python2.7/site-packages/tests/ec2
/usr/lib/python2.7/site-packages/tests/ec2/__init__.py
/usr/lib/python2.7/site-packages/tests/ec2/__init__.pyc
/usr/lib/python2.7/site-packages/tests/ec2/__init__.pyo
/usr/lib/python2.7/site-packages/tests/ec2/cloudwatch
/usr/lib/python2.7/site-packages/tests/ec2/cloudwatch/__init__.py
/usr/lib/python2.7/site-packages/tests/ec2/cloudwatch/__init__.pyc
/usr/lib/python2.7/site-packages/tests/ec2/cloudwatch/__init__.pyo
/usr/lib/python2.7/site-packages/tests/ec2/cloudwatch/test_connection.py
/usr/lib/python2.7/site-packages/tests/ec2/cloudwatch/test_connection.pyc
/usr/lib/python2.7/site-packages/tests/ec2/cloudwatch/test_connection.pyo
/usr/lib/python2.7/site-packages/tests/ec2/elb
/usr/lib/python2.7/site-packages/tests/ec2/elb/test_connection.py
/usr/lib/python2.7/site-packages/tests/ec2/elb/test_connection.pyc
/usr/lib/python2.7/site-packages/tests/ec2/elb/test_connection.pyo
/usr/lib/python2.7/site-packages/tests/ec2/test_connection.py
/usr/lib/python2.7/site-packages/tests/ec2/test_connection.pyc
/usr/lib/python2.7/site-packages/tests/ec2/test_connection.pyo
/usr/lib/python2.7/site-packages/tests/s3
/usr/lib/python2.7/site-packages/tests/s3/__init__.py
/usr/lib/python2.7/site-packages/tests/s3/__init__.pyc
/usr/lib/python2.7/site-packages/tests/s3/__init__.pyo
/usr/lib/python2.7/site-packages/tests/s3/cb_test_harnass.py
/usr/lib/python2.7/site-packages/tests/s3/cb_test_harnass.pyc
/usr/lib/python2.7/site-packages/tests/s3/cb_test_harnass.pyo
/usr/lib/python2.7/site-packages/tests/s3/mock_storage_service.py
/usr/lib/python2.7/site-packages/tests/s3/mock_storage_service.pyc
/usr/lib/python2.7/site-packages/tests/s3/mock_storage_service.pyo
/usr/lib/python2.7/site-packages/tests/s3/other_cacerts.txt
/usr/lib/python2.7/site-packages/tests/s3/test_bucket.py
/usr/lib/python2.7/site-packages/tests/s3/test_bucket.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_bucket.pyo
/usr/lib/python2.7/site-packages/tests/s3/test_connection.py
/usr/lib/python2.7/site-packages/tests/s3/test_connection.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_connection.pyo
/usr/lib/python2.7/site-packages/tests/s3/test_encryption.py
/usr/lib/python2.7/site-packages/tests/s3/test_encryption.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_encryption.pyo
/usr/lib/python2.7/site-packages/tests/s3/test_gsconnection.py
/usr/lib/python2.7/site-packages/tests/s3/test_gsconnection.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_gsconnection.pyo
/usr/lib/python2.7/site-packages/tests/s3/test_https_cert_validation.py
/usr/lib/python2.7/site-packages/tests/s3/test_https_cert_validation.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_https_cert_validation.pyo
/usr/lib/python2.7/site-packages/tests/s3/test_key.py
/usr/lib/python2.7/site-packages/tests/s3/test_key.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_key.pyo
/usr/lib/python2.7/site-packages/tests/s3/test_mfa.py
/usr/lib/python2.7/site-packages/tests/s3/test_mfa.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_mfa.pyo
/usr/lib/python2.7/site-packages/tests/s3/test_multidelete.py
/usr/lib/python2.7/site-packages/tests/s3/test_multidelete.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_multidelete.pyo
/usr/lib/python2.7/site-packages/tests/s3/test_multipart.py
/usr/lib/python2.7/site-packages/tests/s3/test_multipart.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_multipart.pyo
/usr/lib/python2.7/site-packages/tests/s3/test_pool.py
/usr/lib/python2.7/site-packages/tests/s3/test_pool.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_pool.pyo
/usr/lib/python2.7/site-packages/tests/s3/test_resumable_downloads.py
/usr/lib/python2.7/site-packages/tests/s3/test_resumable_downloads.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_resumable_downloads.pyo
/usr/lib/python2.7/site-packages/tests/s3/test_resumable_uploads.py
/usr/lib/python2.7/site-packages/tests/s3/test_resumable_uploads.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_resumable_uploads.pyo
/usr/lib/python2.7/site-packages/tests/s3/test_versioning.py
/usr/lib/python2.7/site-packages/tests/s3/test_versioning.pyc
/usr/lib/python2.7/site-packages/tests/s3/test_versioning.pyo
/usr/lib/python2.7/site-packages/tests/sdb
/usr/lib/python2.7/site-packages/tests/sdb/__init__.py
/usr/lib/python2.7/site-packages/tests/sdb/__init__.pyc
/usr/lib/python2.7/site-packages/tests/sdb/__init__.pyo
/usr/lib/python2.7/site-packages/tests/sdb/test_connection.py
/usr/lib/python2.7/site-packages/tests/sdb/test_connection.pyc
/usr/lib/python2.7/site-packages/tests/sdb/test_connection.pyo
/usr/lib/python2.7/site-packages/tests/sqs
/usr/lib/python2.7/site-packages/tests/sqs/__init__.py
/usr/lib/python2.7/site-packages/tests/sqs/__init__.pyc
/usr/lib/python2.7/site-packages/tests/sqs/__init__.pyo
/usr/lib/python2.7/site-packages/tests/sqs/test_connection.py
/usr/lib/python2.7/site-packages/tests/sqs/test_connection.pyc
/usr/lib/python2.7/site-packages/tests/sqs/test_connection.pyo
/usr/lib/python2.7/site-packages/tests/sts
/usr/lib/python2.7/site-packages/tests/sts/__init__.py
/usr/lib/python2.7/site-packages/tests/sts/__init__.pyc
/usr/lib/python2.7/site-packages/tests/sts/__init__.pyo
/usr/lib/python2.7/site-packages/tests/sts/test_session_token.py
/usr/lib/python2.7/site-packages/tests/sts/test_session_token.pyc
/usr/lib/python2.7/site-packages/tests/sts/test_session_token.pyo
/usr/lib/python2.7/site-packages/tests/test.py
/usr/lib/python2.7/site-packages/tests/test.pyc
/usr/lib/python2.7/site-packages/tests/test.pyo
/usr/lib/python2.7/site-packages/tests/utils
/usr/lib/python2.7/site-packages/tests/utils/test_password.py
/usr/lib/python2.7/site-packages/tests/utils/test_password.pyc
/usr/lib/python2.7/site-packages/tests/utils/test_password.pyo


This is a regression from the python-boto-2.0-2.fc17.noarch

Version-Release number of selected component (if applicable):
python-boto-2.2.2-1.fc17

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2012-03-16 07:45:25 EDT
This flaw has come about due to badly written %files  entries:

  %files
  ...
  %{python_sitelib}/*

This should be re-written as

  %{python_sitelib}/boto/

So that this sort of problem is detected during RPM build phase
Comment 2 Garrett Holmstrom 2012-03-20 17:24:13 EDT
Upstream screwed up setup.py in version 2.2.2 and then fixed it in 2.3.  Perhaps the 2.2.2 package in updates-testing should be replaced.
Comment 3 Fedora Update System 2012-03-20 20:17:58 EDT
python-boto-2.3.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-3890/python-boto-2.3.0-1.fc17
Comment 4 Fedora Update System 2012-03-21 14:20:38 EDT
Package python-boto-2.3.0-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-boto-2.3.0-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3890/python-boto-2.3.0-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-03-27 11:17:27 EDT
python-boto-2.3.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-boto-2.3.0-1.fc17
Comment 6 Fedora Update System 2012-05-02 00:53:13 EDT
python-boto-2.3.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.