Bug 804057 - Initial service lookups having name with uppercase alphabets doesn't work.
Initial service lookups having name with uppercase alphabets doesn't work.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stephen Gallagher
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 08:42 EDT by Kaushik Banerjee
Modified: 2012-06-20 07:56 EDT (History)
4 users (show)

See Also:
Fixed In Version: sssd-1.8.0-20.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:56:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaushik Banerjee 2012-03-16 08:42:29 EDT
Description of problem:
Initial service lookups having name with uppercase alphabets doesn't work.

Version-Release number of selected component (if applicable):
sssd-1.8.0-15

How reproducible:
Always

Steps to Reproduce:
1. Add the following services in ldap server:
dn: cn=Svc4,ou=Services,dc=example,dc=com
objectClass: ipService
cn: svc4_alias1
cn: SVC4_Alias2
ipServicePort: 12345
ipServiceProtocol: Tcp
ipServiceProtocol: udp
ipServiceProtocol: dummy_proto4

dn: cn=Svc6,ou=Services,dc=example,dc=com
objectClass: ipService
cn: svc6_alias1
cn: SVC6_Alias2
cn: SVC6-Alias3
ipServicePort: 6666
ipServiceProtocol: tcp
ipServiceProtocol: udp
ipServiceProtocol: dummy-proto6

2. sssd.conf domain section has:

debug_level=0xFFF0
id_provider = ldap
ldap_uri = ldap://ldapserver.example.com
ldap_search_base = dc=example,dc=com
ldap_tls_cacert = /etc/openldap/cacerts/server.pem
case_sensitive = true

3. Restart sssd with clear cache and lookup the services as follows:
# service sssd stop;rm -f /var/lib/sss/db/*;service sssd start
Stopping sssd:                                             [  OK  ]
Starting sssd:                                             [  OK  ]
# sleep 20
# getent -s sss services Svc4
# getent -s sss services Svc4
# getent -s sss services Svc4
Svc4      12345/Tcp svc4_alias1 SVC4_Alias2        <== I get the output in 3rd or 4th attempt

# getent -s sss services Svc6
# getent -s sss services Svc6
# getent -s sss services Svc6
# getent -s sss services Svc6
Svc6      6666/tcp svc6_alias1 SVC6_Alias2 SVC6-Alias3    <==got the output after 4 attempts.
  
Actual results:
Looking up service with uppercase alphabets doesn't return the output in first attempt

Expected results:
Output should be seen in the first service lookup.

Additional info:
Comment 2 Jakub Hrozek 2012-03-17 17:33:21 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1259
Comment 5 Kaushik Banerjee 2012-04-02 16:14:37 EDT
Verified in version:

# rpm -qi sssd | head
Name        : sssd                         Relocations: (not relocatable)
Version     : 1.8.0                             Vendor: Red Hat, Inc.
Release     : 20.el6                        Build Date: Fri 30 Mar 2012 06:45:57 PM IST
Install Date: Mon 02 Apr 2012 05:36:37 PM IST      Build Host: x86-002.build.bos.redhat.com
Group       : Applications/System           Source RPM: sssd-1.8.0-20.el6.src.rpm
Size        : 7865577                          License: GPLv3+
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://fedorahosted.org/sssd/
Summary     : System Security Services Daemon
Comment 6 Jakub Hrozek 2012-04-03 14:45:57 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed
Comment 8 errata-xmlrpc 2012-06-20 07:56:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html

Note You need to log in before you can comment on or make changes to this bug.