Bug 804100 - subscription-manager release --set should be blocked against older candlepins
subscription-manager release --set should be blocked against older candlepins
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-16 10:37 EDT by John Sefler
Modified: 2013-01-10 05:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:07:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-03-16 10:37:22 EDT
Description of problem:
When configured to an older candlepin, it appears that the new call to release --set is updating the consumer, but is dropping the set value for release.  Instead we should block with a message stating that the version of the configured server.hostname does not support the release functionality.

Version-Release number of selected component (if applicable):
[root@ibm-ls22-04 ~]# rpm -q subscription-manager
subscription-manager-0.99.10-1.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@ibm-ls22-04 ~]# grep hostname /etc/rhsm/rhsm.conf # Server hostname:
hostname=subscription.rhn.stage.redhat.com
proxy_hostname=
^(I was told that this version of candlepin is 0.5.5.2)
[root@ibm-ls22-04 ~]# subscription-manager register --username stage_test_12 --autosubscribe
Password: 
The system has been registered with id: b731baa3-f8ac-441c-84bf-8b7bc06dbd52 
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed               

[root@ibm-ls22-04 ~]# subscription-manager release --list
5.7
5.8
5Server
6.0
6.1
6.2
6.3
6Server
[root@ibm-ls22-04 ~]# subscription-manager release
[root@ibm-ls22-04 ~]# 

^^ PLEASE ADD A FEEDBACK LABEL LIKE:   Release:

[root@ibm-ls22-04 ~]# subscription-manager release --set 6.0
[root@ibm-ls22-04 ~]# 

^^ PLEASE ADD A FEEDBACK LABEL LIKE:   Release: 6.0 (assuming candlepin supports this functionality)

[root@ibm-ls22-04 ~]# subscription-manager release
[root@ibm-ls22-04 ~]# 

^^ BANG! The release value was not set

  

Expected results:
Expected the call to release --set to say that the ability to set a release preference was not supported by the version of the server.hostname configured.


Additional info:


The rhms.log during the call to set the release shows:
2012-03-16 10:27:02,145 [INFO]  @connection.py:487 - Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
2012-03-16 10:27:02,145 [INFO]  @connection.py:498 - Connection Built: host: subscription.rhn.stage.redhat.com, port: 443, handler: /subscription
2012-03-16 10:27:02,148 [DEBUG]  @connection.py:307 - Loading CA PEM certificates from: /etc/rhsm/ca/
2012-03-16 10:27:02,148 [DEBUG]  @connection.py:289 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2012-03-16 10:27:02,148 [DEBUG]  @connection.py:289 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2012-03-16 10:27:02,149 [DEBUG]  @connection.py:328 - Making request: PUT /subscription/consumers/b731baa3-f8ac-441c-84bf-8b7bc06dbd52
2012-03-16 10:27:03,808 [DEBUG]  @connection.py:342 - Response status: 204
Comment 1 James Bowes 2012-03-23 14:11:00 EDT
Fixed in master, 30bf0e77. should be in subscription-manager 0.99.12
Comment 5 Shwetha Kallesh 2012-03-28 07:40:51 EDT
RPM used:
[root@skallesh pki]# rpm -qa | grep subscription-manager
subscription-manager-debuginfo-0.99.12-1.el6.x86_64
subscription-manager-migration-0.99.12-1.git.2.7747155.el6.x86_64
subscription-manager-migration-data-1.12.1.2-1.git.0.9e244c8.el6.noarch
subscription-manager-0.99.12-1.git.2.7747155.el6.x86_64
subscription-manager-firstboot-0.99.12-1.git.2.7747155.el6.x86_64
subscription-manager-gnome-0.99.12-1.git.2.7747155.el6.x86_64


[root@skallesh pki]# subscription-manager release --set=6.0
ERROR: The 'release' command is not supported by the server.

[root@skallesh pki]# subscription-manager release
ERROR: The 'release' command is not supported by the server.
Comment 7 errata-xmlrpc 2012-06-20 09:07:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.