Bug 804109 - When providing invalid credential with rhn-migrate-classic-to-rhsm it throws a generic message
When providing invalid credential with rhn-migrate-classic-to-rhsm it throws ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
:
Depends On: 789008
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-03-16 10:53 EDT by Michael Stead
Modified: 2013-01-07 22:49 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of: 789008
Environment:
Last Closed: 2013-01-07 22:49:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Stead 2012-03-16 10:53:15 EDT
+++ This bug was initially created as a clone of Bug #789008 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
3/3

Prerequisites : 
Rhel5.8 with following rpm 
subscription-manager-migration-0.98.14-1.el5
subscription-manager-0.98.14-1.el5
subscription-manager-migration-data-1.11-1.el5

 Steps: 
Register machine to rhn classic
.
Use rhn-migrate-classic-to-rhsm for migration with invalid rhn credentials.

 Expected Result: The error message should be more specific, some thing like your user name/password is incorrect.

 Actual result: It throws the following error message:
           ----------------------------------------
 [root@ibm-z10-25 yum.repos.d]# rhn-migrate-classic-to-rhsm 
RHN Username: test
Password: 
Unable to connect to certificate server.  See /var/log/rhsm/rhsm.log for more details.

--- Additional comment from awood@redhat.com on 2012-03-15 15:03:01 EDT ---

Committed 7d7208d88c1858104233c1c1a3b262f33916711e

Available subscription-manager-0.99.11+
Comment 1 Michael Stead 2012-03-16 10:55:00 EDT
This bug was fixed as part of 6.3.

Please be sure to reverify on first dev build for RHEL5.9
Comment 2 Alex Wood 2012-06-21 10:37:46 EDT
It looks like this bug has regressed in RHEL 5.9 due to a change I made to add SLA selection.  The fix for this regression is fairly simple; however, the fix uncovers another more serious bug with i18n error messages.  Printing the error returned by the server results in an UnicodeEncodeError when the i18n text is printed to stderr.  Until I find a fix for this more serious error, I am hesitant to commit the fix for the regression.
Comment 4 Alex Wood 2012-06-25 16:23:05 EDT
commit f97af2b6af17bb862e31363b51254a61cabaa394
Refs: <origin/awood/804109>, 804109, subscription-manager-1.0.4-1-35-gf97af2b
Author:     Alex Wood <awood@redhat.com>
AuthorDate: Mon Jun 25 13:28:28 2012 -0400
Commit:     Alex Wood <awood@redhat.com>
CommitDate: Mon Jun 25 13:28:28 2012 -0400

    804109: Give a specific message when providing invalid credentials.
Comment 5 Shwetha Kallesh 2012-06-26 02:19:04 EDT
Verified!!


RPM:
[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-gui-1.0.4-1.git.35.f97af2b.el5
subscription-manager-firstboot-1.0.4-1.git.35.f97af2b.el5
subscription-manager-migration-1.0.4-1.git.35.f97af2b.el5
subscription-manager-1.0.4-1.git.35.f97af2b.el5


[root@dhcp201-196 ~]# rhn-migrate-classic-to-rhsm
RHN Username: asfsaf
Password: 
Unable to connect to certificate server: Invalid username or password. To create a login, please visit https://www.redhat.com/wapps/ugc/register.html.  See /var/log/rhsm/rhsm.log for more details.
Comment 6 RHEL Product and Program Management 2012-06-26 14:08:47 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 8 errata-xmlrpc 2013-01-07 22:49:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.