Bug 804111 - Exception is thrown during startup SOA-P 5.3.0 DR2 (with all DBs)
Exception is thrown during startup SOA-P 5.3.0 DR2 (with all DBs)
Status: CLOSED WONTFIX
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.3.0 GA
Unspecified Unspecified
medium Severity urgent
: ER3
: 5.3.0 GA
Assigned To: Kevin Conner
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 10:57 EDT by Filip Elias
Modified: 2012-06-06 11:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
SOA-P 5.3.0 DR2 with IBM DB2 9.7
Last Closed: 2012-06-06 11:28:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Boot log of Soa-p 5.3.0 DR2 with IBM DB2 9.7 (376.61 KB, text/x-log)
2012-03-16 10:57 EDT, Filip Elias
no flags Details

  None (edit)
Description Filip Elias 2012-03-16 10:57:32 EDT
Created attachment 570625 [details]
Boot log of Soa-p 5.3.0 DR2 with IBM DB2 9.7

During startup of SOA-P 5.3.0 DR2 with DB2 9.7 exception is thrown:

org.jboss.deployers.spi.DeploymentException: Error deploying: file:/qa/hudson_ws/workspace/soa-it-single-felias/jbosssoa/jboss-as/server/db2-97/conf/bootstrap/vfs.xml

and 

org.jboss.deployers.spi.DeploymentException: Error deploying: file:/qa/hudson_ws/workspace/soa-it-single-felias/jbosssoa/jboss-as/server/db2-97/conf/bootstrap/logging.xml

Boot log is in the attachment.
Comment 1 Rick Wagner 2012-03-19 17:20:27 EDT
GSS considers this a medium priority, we should fix it.
Comment 4 Filip Elias 2012-04-05 08:36:45 EDT
These exceptions are thrown with all databases, not only with DB2-9.7.
Comment 5 Nick Cross 2012-05-30 08:18:19 EDT
Unable to reproduce this using SOA-P ER3 and PostgreSQL
Comment 6 Nick Cross 2012-05-31 07:58:16 EDT
Scratch above the errors occur but only in boot.log
Comment 9 kconner 2012-06-06 11:24:04 EDT
This seems to be an inherent issue in EAP as evidenced by

https://community.jboss.org/wiki/ClassLoaderHasNotBeenSetExceptionInBootlog

This issue exists irrespective of which DB is being used.
Comment 10 Nick Cross 2012-06-06 11:28:03 EDT
Marking as wontfix as advised by Julian as it is dependent on upstream fixing the issue.

Note You need to log in before you can comment on or make changes to this bug.