Bug 804206 - (guano) rubygem-thin code contains expletives that are returned in every respone header
rubygem-thin code contains expletives that are returned in every respone header
Status: CLOSED NOTABUG
Product: CloudForms Common
Classification: Red Hat
Component: rubygem-thin (Show other bugs)
1.0.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Katello Internal Mailing List
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 16:18 EDT by Brad P. Crochet
Modified: 2012-09-12 11:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 10:11:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SRC patch file (275 bytes, patch)
2012-03-19 14:44 EDT, Bryan Kearney
no flags Details | Diff
spec file patch (1.07 KB, patch)
2012-03-19 14:45 EDT, Bryan Kearney
no flags Details | Diff

  None (edit)
Description Brad P. Crochet 2012-03-16 16:18:07 EDT
Description of problem:
The rubygem-thin server has a code name of "Bat-Shit Crazy". While hilarious, I don't think we want to ship that. It is returned in every response header when talking to katello REST api. 

Version-Release number of selected component (if applicable):
rubygem-thin-1.2.11-3.el6.x86_64

How reproducible:
Extremely

Steps to Reproduce:
1. curl -k -v https://any.katello.server/katello/api
  
Actual results:
> GET /katello/api/ HTTP/1.1
> User-Agent: curl/7.21.7 (x86_64-redhat-linux-gnu) libcurl/7.21.7 NSS/3.13.1.0 zlib/1.2.5 libidn/1.22 libssh2/1.2.7
> Host: bcrochet-katello.usersys.redhat.com
> Accept: */*
> 
< HTTP/1.1 200 OK
< Date: Fri, 16 Mar 2012 20:16:35 GMT
< Server: thin 1.2.11 codename Bat-Shit Crazy
< X-Runtime: 0.005891
< Cache-Control: max-age=0, private, must-revalidate
< Content-Type: application/json; charset=utf-8
< ETag: "347ff10b3b9ae234f07da7d0f9fb1bd9"
< X-UA-Compatible: IE=Edge,chrome=1
< Connection: close
< Transfer-Encoding: chunked


Expected results:
No "shit".
Comment 1 Mike McCune 2012-03-19 11:46:13 EDT
FYI, the ruby file that contains this version string is in:

/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/version.rb

  CODENAME = "Bat-Shit Crazy".freeze
Comment 4 Bryan Kearney 2012-03-19 14:44:37 EDT
Created attachment 571205 [details]
SRC patch file
Comment 5 Bryan Kearney 2012-03-19 14:45:03 EDT
Created attachment 571206 [details]
spec file patch
Comment 9 Bryan Kearney 2012-09-06 10:53:27 EDT
perhaps we just upgrade to the latest releaase?
Comment 12 Dave Johnson 2012-09-07 10:11:52 EDT
Triage meeting between pm/dev/qe agreed to close this as not a bug

Note You need to log in before you can comment on or make changes to this bug.