Bug 804218 - Cannot unmount NFS share if Mount version 2 is disabled.
Cannot unmount NFS share if Mount version 2 is disabled.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
:
Depends On: 595675
Blocks: 804681
  Show dependency treegraph
 
Reported: 2012-03-16 17:27 EDT by Orion Poplawski
Modified: 2012-03-19 11:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 595675
: 804681 (view as bug list)
Environment:
Last Closed: 2012-03-19 11:12:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2012-03-16 17:27:40 EDT
Hopefully cloning this is useful.  On EL6 you cannot disable just version 1, but you can disable version 2 (which also disables version 1).  If you do, you get the same problem as before with EL5 and version 1.

+++ This bug was initially created as a clone of Bug #595675 +++

Reproducer:

On server:
edit /etc/sysconfig/nfs and set  MOUNTD_NFS_V2=no
restart nfs

On client: 
Mount a share from the server. This should be successful.
Now try to unmount it. This fails with an error.

# umount /mnt
umount.nfs: vm22:/exports: not found / mounted or server not reachable
umount.nfs: vm22:/exports: not found / mounted or server not reachable


The cause appears to be the fact that the client when mounting uses MOUNT version 3 protocol. However when unmounting, it appears to use version 1 of the MOUNT protocol. Since version 1 is disabled, the client cannot unmount.

--- Additional comment from steved@redhat.com on 2011-01-21 13:47:14 EST ---

Created attachment 474657 [details]
The patch that fixes the problem

--- Additional comment from errata-xmlrpc@redhat.com on 2011-07-21 07:35:22 EDT ---

An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1048.html
Comment 2 Orion Poplawski 2012-03-16 17:34:02 EDT
Oops, maybe this is just still an issue with EL5 clients and version 2 being disabled on the server.  Just tested with EL6 client and was able to unmount.
Comment 3 Orion Poplawski 2012-03-16 17:44:03 EDT
nfs-utils-1.0.9-60.el5
Comment 4 Steve Dickson 2012-03-19 08:01:09 EDT
(In reply to comment #2)
> Oops, maybe this is just still an issue with EL5 clients and version 2 being
> disabled on the server.  Just tested with EL6 client and was able to unmount.
A bit confused... Can close this bz or is there still a problem with RHEL6 (or even RHEL5)?
Comment 5 Orion Poplawski 2012-03-19 10:47:09 EDT
Sorry about that.  There does not appear to be a problem with RHEL6, but there is with RHEL5 client - can't unmount if the server has disabled version 2.  So this either needs to get reassign back to RHEL5 or closed if we can't do that.
Comment 6 Steve Dickson 2012-03-19 11:12:03 EDT
I just opened this clone:
   https://bugzilla.redhat.com/show_bug.cgi?id=804681

Note You need to log in before you can comment on or make changes to this bug.