Bug 804238 - SELinux is preventing /usr/libexec/ck-get-x11-server-pid from 'connectto' accesses on the unix_stream_socket @/tmp/.X11-unix/X0.
SELinux is preventing /usr/libexec/ck-get-x11-server-pid from 'connectto' acc...
Status: CLOSED DUPLICATE of bug 804235
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:db8d630977597c521f0966d37b9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 19:37 EDT by Horst H. von Brand
Modified: 2012-03-19 11:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 11:20:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2012-03-16 19:37:57 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.7-1.fc16.x86_64
reason:         SELinux is preventing /usr/libexec/ck-get-x11-server-pid from 'connectto' accesses on the unix_stream_socket @/tmp/.X11-unix/X0.
time:           Fri 16 Mar 2012 07:37:42 PM CLT

description:
:SELinux is preventing /usr/libexec/ck-get-x11-server-pid from 'connectto' accesses on the unix_stream_socket @/tmp/.X11-unix/X0.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that ck-get-x11-server-pid should be allowed connectto access on the X0 unix_stream_socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep ck-get-x11-serv /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:consolekit_t:s0
:Target Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
:Target Objects                @/tmp/.X11-unix/X0 [ unix_stream_socket ]
:Source                        ck-get-x11-serv
:Source Path                   /usr/libexec/ck-get-x11-server-pid
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           ConsoleKit-x11-0.4.5-1.fc15.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.7-1.fc16.x86_64 #1
:                              SMP Tue Feb 21 01:40:47 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Fri 16 Mar 2012 07:30:31 PM CLT
:Last Seen                     Fri 16 Mar 2012 07:31:03 PM CLT
:Local ID                      19690912-efcd-409a-a2ec-515479cc02d7
:
:Raw Audit Messages
:type=AVC msg=audit(1331940663.427:178): avc:  denied  { connectto } for  pid=1992 comm="ck-get-x11-serv" path=002F746D702F2E5831312D756E69782F5830 scontext=system_u:system_r:consolekit_t:s0 tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tclass=unix_stream_socket
:
:
:type=SYSCALL msg=audit(1331940663.427:178): arch=x86_64 syscall=connect success=no exit=EACCES a0=3 a1=7fffa07801e0 a2=14 a3=7fffa07801e3 items=0 ppid=1991 pid=1992 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=ck-get-x11-serv exe=/usr/libexec/ck-get-x11-server-pid subj=system_u:system_r:consolekit_t:s0 key=(null)
:
:Hash: ck-get-x11-serv,consolekit_t,xdm_t,unix_stream_socket,connectto
:
:audit2allow
:
:#============= consolekit_t ==============
:allow consolekit_t xdm_t:unix_stream_socket connectto;
:
:audit2allow -R
:
:#============= consolekit_t ==============
:allow consolekit_t xdm_t:unix_stream_socket connectto;
:
Comment 1 Miroslav Grepl 2012-03-19 11:20:24 EDT

*** This bug has been marked as a duplicate of bug 804235 ***

Note You need to log in before you can comment on or make changes to this bug.