Bug 804246 - SELinux is preventing systemd-logind from 'remove_name' accesses on the directory X11-display.
SELinux is preventing systemd-logind from 'remove_name' accesses on the direc...
Status: CLOSED DUPLICATE of bug 804237
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0efbaf84a0a618fbbf4b1182d3b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 20:08 EDT by Horst H. von Brand
Modified: 2012-03-17 06:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-17 06:58:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2012-03-16 20:08:35 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.9-2.fc16.x86_64
reason:         SELinux is preventing systemd-logind from 'remove_name' accesses on the directory X11-display.
time:           Fri 16 Mar 2012 09:08:16 PM CLST

description:
:SELinux is preventing systemd-logind from 'remove_name' accesses on the directory X11-display.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that systemd-logind should be allowed remove_name access on the X11-display directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemd-logind /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:systemd_logind_t:s0
:Target Context                system_u:object_r:var_run_t:s0
:Target Objects                X11-display [ dir ]
:Source                        systemd-logind
:Source Path                   systemd-logind
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           systemd-37-15.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.9-2.fc16.x86_64 #1
:                              SMP Mon Mar 5 20:55:39 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Fri 16 Mar 2012 09:05:36 PM CLST
:Last Seen                     Fri 16 Mar 2012 09:05:59 PM CLST
:Local ID                      5d4a234d-b7c8-4ded-8372-3f11e1cdf7f6
:
:Raw Audit Messages
:type=AVC msg=audit(1331942759.497:167): avc:  denied  { remove_name } for  pid=1903 comm="systemd-logind" name="X11-display" dev=tmpfs ino=26729 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1331942759.497:167): avc:  denied  { unlink } for  pid=1903 comm="systemd-logind" name="X11-display" dev=tmpfs ino=26729 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=lnk_file
:
:
:type=SYSCALL msg=audit(1331942759.497:167): arch=x86_64 syscall=unlink success=yes exit=0 a0=16d6f00 a1=421a5b a2=79616c70 a3=1f items=0 ppid=1 pid=1903 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemd-logind exe=/lib/systemd/systemd-logind subj=system_u:system_r:systemd_logind_t:s0 key=(null)
:
:Hash: systemd-logind,systemd_logind_t,var_run_t,dir,remove_name
:
:audit2allow
:
:#============= systemd_logind_t ==============
:allow systemd_logind_t var_run_t:dir remove_name;
:allow systemd_logind_t var_run_t:lnk_file unlink;
:
:audit2allow -R
:
:#============= systemd_logind_t ==============
:allow systemd_logind_t var_run_t:dir remove_name;
:allow systemd_logind_t var_run_t:lnk_file unlink;
:
Comment 1 Daniel Walsh 2012-03-17 06:58:18 EDT

*** This bug has been marked as a duplicate of bug 804237 ***

Note You need to log in before you can comment on or make changes to this bug.