Bug 804247 - SELinux is preventing /usr/bin/Xorg from 'execute' accesses on the file /sbin/modprobe.
SELinux is preventing /usr/bin/Xorg from 'execute' accesses on the file /sbin...
Status: CLOSED DUPLICATE of bug 804244
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:cd756909411b7d8cbec6417e0c4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 20:23 EDT by Horst H. von Brand
Modified: 2012-03-17 06:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-17 06:58:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2012-03-16 20:23:32 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.9-2.fc16.x86_64
reason:         SELinux is preventing /usr/bin/Xorg from 'execute' accesses on the file /sbin/modprobe.
time:           Fri 16 Mar 2012 09:23:19 PM CLST

description:
:SELinux is preventing /usr/bin/Xorg from 'execute' accesses on the file /sbin/modprobe.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that Xorg should be allowed execute access on the modprobe file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep Xorg /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:insmod_exec_t:s0
:Target Objects                /sbin/modprobe [ file ]
:Source                        Xorg
:Source Path                   /usr/bin/Xorg
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           xorg-x11-server-Xorg-1.11.4-1.fc16.x86_64
:Target RPM Packages           module-init-tools-3.16-5.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.9-2.fc16.x86_64 #1
:                              SMP Mon Mar 5 20:55:39 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Fri 16 Mar 2012 09:05:28 PM CLST
:Last Seen                     Fri 16 Mar 2012 09:05:28 PM CLST
:Local ID                      aca7dc72-c708-486a-9738-cacf030b2fcf
:
:Raw Audit Messages
:type=AVC msg=audit(1331942728.957:96): avc:  denied  { execute } for  pid=1298 comm="Xorg" name="modprobe" dev=dm-3 ino=1048 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:insmod_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1331942728.957:96): arch=x86_64 syscall=execve success=no exit=EACCES a0=7fff6b865cc0 a1=7fff6b863c20 a2=7fff6b866780 a3=20 items=0 ppid=1294 pid=1298 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=Xorg exe=/usr/bin/Xorg subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)
:
:Hash: Xorg,xdm_t,insmod_exec_t,file,execute
:
:audit2allow
:
:#============= xdm_t ==============
:allow xdm_t insmod_exec_t:file execute;
:
:audit2allow -R
:
:#============= xdm_t ==============
:allow xdm_t insmod_exec_t:file execute;
:
Comment 1 Daniel Walsh 2012-03-17 06:58:57 EDT

*** This bug has been marked as a duplicate of bug 804244 ***

Note You need to log in before you can comment on or make changes to this bug.