Bug 804252 - Error with YUM Extender
Error with YUM Extender
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 21:13 EDT by Bruno Martins
Modified: 2014-01-21 18:21 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 02:31:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Martins 2012-03-16 21:13:26 EDT
This is detailed YUM Extender output:

01:08:02 : network interface eth1 (wl) is connected
01:08:02 : Connected to an network
01:08:02 : network interface eth1 (wl) is connected
01:08:02 : Starting yum child process
01:08:05 : YUM: Yum Version : 3.4.3
01:08:05 : YUM: Loaded plugins: langpacks, presto
01:08:05 : Getting available updates
01:08:07 : 0 packages returned
01:08:07 : Getting available obsoletes
01:08:07 : 0 packages returned
01:08:07 : Adding Packages to view
01:08:07 : Added 0 Packages to view
01:09:14 : YUM: --> Running transaction check
01:09:14 : YUM: ---> Package httpd.x86_64 0:2.2.22-2.fc16 will be erased
01:09:14 : YUM: --> Processing Dependency: httpd for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:14 : YUM: --> Processing Dependency: httpd for package: dojo-1.6.1-1.fc16.noarch
01:09:14 : YUM: --> Processing Dependency: httpd for package: eclipse-phpeclipse-1.2.3-3.fc15.noarch
01:09:14 : YUM: ---> Package mysql-server.x86_64 0:5.5.21-1.fc16 will be erased
01:09:14 : YUM: --> Processing Dependency: mysql-server for package: akonadi-1.7.1-1.fc16.x86_64
01:09:14 : YUM: ---> Package php.x86_64 0:5.3.10-1.fc16 will be erased
01:09:14 : YUM: --> Processing Dependency: php >= 5.2.0 for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:14 : YUM: ---> Package php-mysql.x86_64 0:5.3.10-1.fc16 will be installed
01:09:14 : YUM: --> Processing Dependency: php-pdo(x86-64) = 5.3.10-1.fc16 for package: php-mysql-5.3.10-1.fc16.x86_64
01:09:14 : YUM: ---> Package phpMyAdmin.noarch 0:3.4.9-1.fc16 will be installed
01:09:15 : YUM: --> Processing Dependency: php-mcrypt >= 5.2.0 for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:15 : YUM: --> Processing Dependency: php-mbstring >= 5.2.0 for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:15 : YUM: --> Processing Dependency: php-gd >= 5.2.0 for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:15 : YUM: --> Processing Dependency: php-php-gettext for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:15 : YUM: --> Processing Dependency: httpd for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:15 : YUM: --> Running transaction check
01:09:15 : YUM: ---> Package akonadi.x86_64 0:1.7.1-1.fc16 will be erased
01:09:15 : YUM: ---> Package dojo.noarch 0:1.6.1-1.fc16 will be erased
01:09:15 : YUM: ---> Package eclipse-phpeclipse.noarch 0:1.2.3-3.fc15 will be erased
01:09:15 : YUM: ---> Package httpd.x86_64 0:2.2.22-2.fc16 will be erased
01:09:15 : YUM: --> Processing Dependency: httpd-mmn = 20051115-x86-32 for package: php-5.3.10-1.fc16.i686
01:09:15 : YUM: --> Processing Dependency: httpd for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:15 : YUM: --> Processing Dependency: httpd for package: php-5.3.10-1.fc16.i686
01:09:15 : YUM: ---> Package php.i686 0:5.3.10-1.fc16 will be installed
01:09:15 : YUM: --> Processing Dependency: php-common(x86-32) = 5.3.10-1.fc16 for package: php-5.3.10-1.fc16.i686
01:09:15 : YUM: --> Processing Dependency: php-cli(x86-32) = 5.3.10-1.fc16 for package: php-5.3.10-1.fc16.i686
01:09:15 : YUM: --> Processing Dependency: httpd-mmn = 20051115-x86-32 for package: php-5.3.10-1.fc16.i686
01:09:15 : YUM: --> Processing Dependency: libpcre.so.0 for package: php-5.3.10-1.fc16.i686
01:09:15 : YUM: --> Processing Dependency: libgmp.so.3 for package: php-5.3.10-1.fc16.i686
01:09:15 : YUM: --> Processing Dependency: libbz2.so.1 for package: php-5.3.10-1.fc16.i686
01:09:15 : YUM: --> Processing Dependency: httpd for package: php-5.3.10-1.fc16.i686
01:09:15 : YUM: ---> Package php-gd.x86_64 0:5.3.10-1.fc16 will be installed
01:09:15 : YUM: ---> Package php-mbstring.x86_64 0:5.3.10-1.fc16 will be installed
01:09:15 : YUM: ---> Package php-mcrypt.x86_64 0:5.3.10-1.fc16 will be installed
01:09:15 : YUM: --> Processing Dependency: libmcrypt.so.4()(64bit) for package: php-mcrypt-5.3.10-1.fc16.x86_64
01:09:15 : YUM: ---> Package php-pdo.x86_64 0:5.3.10-1.fc16 will be installed
01:09:15 : YUM: ---> Package php-php-gettext.noarch 0:1.0.11-3.fc16 will be installed
01:09:15 : YUM: ---> Package phpMyAdmin.noarch 0:3.4.9-1.fc16 will be installed
01:09:15 : YUM: --> Processing Dependency: httpd for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:15 : YUM: --> Running transaction check
01:09:15 : YUM: ---> Package bzip2-libs.i686 0:1.0.6-3.fc15 will be installed
01:09:15 : YUM: ---> Package gmp.i686 1:4.3.2-4.fc16 will be installed
01:09:15 : YUM: ---> Package httpd.x86_64 0:2.2.22-2.fc16 will be erased
01:09:15 : YUM: --> Processing Dependency: httpd-mmn = 20051115-x86-32 for package: php-5.3.10-1.fc16.i686
01:09:15 : YUM: --> Processing Dependency: httpd for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:15 : YUM: --> Processing Dependency: httpd for package: php-5.3.10-1.fc16.i686
01:09:15 : YUM: ---> Package libmcrypt.x86_64 0:2.5.8-10.fc15 will be installed
01:09:15 : YUM: ---> Package pcre.i686 0:8.12-7.fc16 will be installed
01:09:15 : YUM: ---> Package php.i686 0:5.3.10-1.fc16 will be installed
01:09:16 : YUM: --> Processing Dependency: httpd-mmn = 20051115-x86-32 for package: php-5.3.10-1.fc16.i686
01:09:16 : YUM: --> Processing Dependency: httpd for package: php-5.3.10-1.fc16.i686
01:09:16 : YUM: ---> Package php-cli.i686 0:5.3.10-1.fc16 will be installed
01:09:16 : YUM: --> Processing Dependency: libedit.so.0 for package: php-cli-5.3.10-1.fc16.i686
01:09:16 : YUM: ---> Package php-common.i686 0:5.3.10-1.fc16 will be installed
01:09:16 : YUM: ---> Package phpMyAdmin.noarch 0:3.4.9-1.fc16 will be installed
01:09:16 : YUM: --> Processing Dependency: httpd for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:16 : YUM: --> Running transaction check
01:09:16 : YUM: ---> Package httpd.x86_64 0:2.2.22-2.fc16 will be erased
01:09:16 : YUM: --> Processing Dependency: httpd-mmn = 20051115-x86-32 for package: php-5.3.10-1.fc16.i686
01:09:16 : YUM: --> Processing Dependency: httpd for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:16 : YUM: --> Processing Dependency: httpd for package: php-5.3.10-1.fc16.i686
01:09:16 : YUM: ---> Package libedit.i686 0:3.0-4.20110227cvs.fc16 will be installed
01:09:16 : YUM: ---> Package php.i686 0:5.3.10-1.fc16 will be installed
01:09:16 : YUM: --> Processing Dependency: httpd-mmn = 20051115-x86-32 for package: php-5.3.10-1.fc16.i686
01:09:16 : YUM: --> Processing Dependency: httpd for package: php-5.3.10-1.fc16.i686
01:09:16 : YUM: ---> Package phpMyAdmin.noarch 0:3.4.9-1.fc16 will be installed
01:09:16 : YUM: --> Processing Dependency: httpd for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:09:38 : YUM: --> Finished Dependency Resolution
01:09:58 : ERROR: Dependency resolving completed with errors
01:09:58 : ERROR:   Package: php-5.3.10-1.fc16.i686 (updates)
    Requires: httpd
    Removing: httpd-2.2.22-2.fc16.x86_64 (@updates-testing)
        httpd = 2.2.22-2.fc16
    Available: httpd-2.2.21-1.fc16.x86_64 (fedora)
        httpd = 2.2.21-1.fc16
    Available: httpd-2.2.22-1.fc16.x86_64 (updates)
        httpd = 2.2.22-1.fc16
01:09:58 : ERROR:   Package: phpMyAdmin-3.4.9-1.fc16.noarch (updates)
    Requires: httpd
    Removing: httpd-2.2.22-2.fc16.x86_64 (@updates-testing)
        httpd = 2.2.22-2.fc16
    Available: httpd-2.2.21-1.fc16.x86_64 (fedora)
        httpd = 2.2.21-1.fc16
    Available: httpd-2.2.22-1.fc16.x86_64 (updates)
        httpd = 2.2.22-1.fc16
01:09:58 : ERROR:   Package: php-5.3.10-1.fc16.i686 (updates)
    Requires: httpd-mmn = 20051115-x86-32
    Removing: httpd-2.2.22-2.fc16.x86_64 (@updates-testing)
        httpd-mmn = 20051115
        httpd-mmn = 20051115-x86-64
    Available: httpd-2.2.21-1.fc16.x86_64 (fedora)
        httpd-mmn = 20051115
        httpd-mmn = 20051115-x86-64
    Available: httpd-2.2.22-1.fc16.x86_64 (updates)
        httpd-mmn = 20051115-x86-64
        httpd-mmn = 20051115
01:10:06 : YUM: --> Running transaction check
01:10:06 : YUM: ---> Package mysql-server.x86_64 0:5.5.21-1.fc16 will be erased
01:10:06 : YUM: --> Processing Dependency: mysql-server for package: akonadi-1.7.1-1.fc16.x86_64
01:10:06 : YUM: ---> Package php.x86_64 0:5.3.10-1.fc16 will be erased
01:10:06 : YUM: --> Processing Dependency: php >= 5.2.0 for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:10:06 : YUM: --> Processing Dependency: php >= 5 for package: eclipse-phpeclipse-1.2.3-3.fc15.noarch
01:10:06 : YUM: ---> Package php-mysql.x86_64 0:5.3.10-1.fc16 will be installed
01:10:06 : YUM: --> Processing Dependency: php-pdo(x86-64) = 5.3.10-1.fc16 for package: php-mysql-5.3.10-1.fc16.x86_64
01:10:06 : YUM: ---> Package phpMyAdmin.noarch 0:3.4.9-1.fc16 will be installed
01:10:06 : YUM: --> Processing Dependency: php-mcrypt >= 5.2.0 for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:10:06 : YUM: --> Processing Dependency: php-mbstring >= 5.2.0 for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:10:06 : YUM: --> Processing Dependency: php-gd >= 5.2.0 for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:10:06 : YUM: --> Processing Dependency: php-php-gettext for package: phpMyAdmin-3.4.9-1.fc16.noarch
01:10:06 : YUM: --> Running transaction check
01:10:06 : YUM: ---> Package akonadi.x86_64 0:1.7.1-1.fc16 will be erased
01:10:06 : YUM: ---> Package eclipse-phpeclipse.noarch 0:1.2.3-3.fc15 will be erased
01:10:06 : YUM: ---> Package php.i686 0:5.3.10-1.fc16 will be installed
01:10:06 : YUM: --> Processing Dependency: php-common(x86-32) = 5.3.10-1.fc16 for package: php-5.3.10-1.fc16.i686
01:10:06 : YUM: --> Processing Dependency: php-cli(x86-32) = 5.3.10-1.fc16 for package: php-5.3.10-1.fc16.i686
01:10:06 : YUM: --> Processing Dependency: libpcre.so.0 for package: php-5.3.10-1.fc16.i686
01:10:06 : YUM: --> Processing Dependency: libgmp.so.3 for package: php-5.3.10-1.fc16.i686
01:10:06 : YUM: --> Processing Dependency: libbz2.so.1 for package: php-5.3.10-1.fc16.i686
01:10:06 : YUM: ---> Package php-gd.x86_64 0:5.3.10-1.fc16 will be installed
01:10:06 : YUM: ---> Package php-mbstring.x86_64 0:5.3.10-1.fc16 will be installed
01:10:06 : YUM: ---> Package php-mcrypt.x86_64 0:5.3.10-1.fc16 will be installed
01:10:06 : YUM: --> Processing Dependency: libmcrypt.so.4()(64bit) for package: php-mcrypt-5.3.10-1.fc16.x86_64
01:10:06 : YUM: ---> Package php-pdo.x86_64 0:5.3.10-1.fc16 will be installed
01:10:06 : YUM: ---> Package php-php-gettext.noarch 0:1.0.11-3.fc16 will be installed
01:10:06 : YUM: --> Running transaction check
01:10:07 : YUM: ---> Package bzip2-libs.i686 0:1.0.6-3.fc15 will be installed
01:10:07 : YUM: ---> Package gmp.i686 1:4.3.2-4.fc16 will be installed
01:10:07 : YUM: ---> Package libmcrypt.x86_64 0:2.5.8-10.fc15 will be installed
01:10:07 : YUM: ---> Package pcre.i686 0:8.12-7.fc16 will be installed
01:10:07 : YUM: ---> Package php-cli.i686 0:5.3.10-1.fc16 will be installed
01:10:07 : YUM: --> Processing Dependency: libedit.so.0 for package: php-cli-5.3.10-1.fc16.i686
01:10:07 : YUM: ---> Package php-common.i686 0:5.3.10-1.fc16 will be installed
01:10:07 : YUM: --> Running transaction check
01:10:07 : YUM: ---> Package libedit.i686 0:3.0-4.20110227cvs.fc16 will be installed
01:10:07 : YUM: --> Finished Dependency Resolution
01:10:08 : Downloaded : (1/15): bzip2-libs-1.0.6-3.fc15.i686.rpm ( 37 k )
01:10:08 : Downloaded : (2/15): gmp-4.3.2-4.fc16.i686.rpm ( 221 k )
01:10:08 : Downloaded : (3/15): libedit-3.0-4.20110227cvs.fc16.i686.rpm ( 85 k )
01:10:08 : Downloaded : (4/15): libmcrypt-2.5.8-10.fc15.x86_64.rpm ( 93 k )
01:10:09 : Downloaded : (5/15): pcre-8.12-7.fc16.i686.rpm ( 226 k )
01:10:10 : Downloaded : (6/15): php-5.3.10-1.fc16.i686.rpm ( 2.3 M )
01:10:11 : Downloaded : (7/15): php-cli-5.3.10-1.fc16.i686.rpm ( 2.2 M )
01:10:12 : Downloaded : (8/15): php-common-5.3.10-1.fc16.i686.rpm ( 501 k )
01:10:12 : Downloaded : (9/15): php-gd-5.3.10-1.fc16.x86_64.rpm ( 107 k )
01:10:12 : Downloaded : (10/15): php-mbstring-5.3.10-1.fc16.x86_64.rpm ( 426 k )
01:10:12 : Downloaded : (11/15): php-mcrypt-5.3.10-1.fc16.x86_64.rpm ( 32 k )
01:10:12 : Downloaded : (12/15): php-mysql-5.3.10-1.fc16.x86_64.rpm ( 80 k )
01:10:13 : Downloaded : (13/15): php-pdo-5.3.10-1.fc16.x86_64.rpm ( 74 k )
01:10:13 : Downloaded : (14/15): php-php-gettext-1.0.11-3.fc16.noarch.rpm ( 21 k )
01:10:14 : Downloaded : (15/15): phpMyAdmin-3.4.9-1.fc16.noarch.rpm ( 4.0 M )
01:10:14 : YUM: Running Transaction Check
01:10:15 : ERROR: Error in yum Transaction : [u'ERROR with transaction check vs depsolve:', 'httpd-mmn = 20051115-x86-32 is needed by php-5.3.10-1.fc16.i686', u'Please report this error at https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum']

And this is why I'm reporting this here. :-)

Best regards,

Bruno Martins
Comment 1 Fedora End Of Life 2013-04-03 13:38:51 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 2 Joergen Thomsen 2013-05-19 14:05:04 EDT
It is preventing updates of Fedora 18.

Fix or workaround ASAP, please
Comment 3 Jan Zeleny 2013-05-20 02:31:22 EDT
Not a bug in yum. The error message only reports current state of packages on your system. The php package is holding back the update of httpd-mmn. Remove the php package and the rest of the update should go fine.

Note You need to log in before you can comment on or make changes to this bug.