Bug 804295 - Running update using vmlinuz/initrd.img/squashfs.img on /boot fails
Running update using vmlinuz/initrd.img/squashfs.img on /boot fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-17 09:19 EDT by Stefan Becker
Modified: 2013-01-10 01:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 18:34:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (11.14 KB, text/plain)
2012-03-19 00:45 EDT, Stefan Becker
no flags Details
program.log (81.56 KB, text/plain)
2012-03-19 00:46 EDT, Stefan Becker
no flags Details
syslog (102.81 KB, text/plain)
2012-03-19 00:46 EDT, Stefan Becker
no flags Details

  None (edit)
Description Stefan Becker 2012-03-17 09:19:15 EDT
Description of problem:

I'm trying to upgrade my Fedora 16. As usual I have downloaded vmlinuz, initrd.img and (new for F17) LiveOS/squasfs.img from the F17 repo and installed them on /boot. I've created a grub2 entry to boot this install Linux with

   linux /vmlinuz root=live:UUID=... rd.luks=0 rd.md=0 rd.dm=0
   initrd /initrd.img

Then I reboot the machine and select this install entry in grub. Everything works fine:

  - kernel boots
  - initrd starts
  - live image starts
  - Anaconda starts
  - Select "Basic storage"
  - Anaconda scans disk, finds my LUKS
  - enter LUKS password
  - Select "Update existing Fedora 16" on my / partition

But now Anaconda fails with 

   "An error occurred mounting device /dev/sda1 as /boot: mount failed... /dev/sda1 is already mounted or /mnt/sysimage/boot busy..."

This is a fatal error and therefore Anaconda aborts the installation.

This comes as no surprise, because /dev/sda1 (=/boot) is busy serving the live image. Shouldn't Anaconda at least try a --bind mount instead?


Version-Release number of selected component (if applicable): boot Message says "Welcome to Anaconda 17.11"

How reproducible: Always
Comment 1 Chris Lumens 2012-03-18 22:46:43 EDT
Please attach /tmp/anaconda.log, /tmp/program.log, and /tmp/syslog to this bug report.
Comment 2 Stefan Becker 2012-03-19 00:45:27 EDT
Created attachment 570997 [details]
anaconda.log
Comment 3 Stefan Becker 2012-03-19 00:46:04 EDT
Created attachment 570998 [details]
program.log
Comment 4 Stefan Becker 2012-03-19 00:46:45 EDT
Created attachment 570999 [details]
syslog
Comment 5 Jesse Keating 2012-07-18 18:34:35 EDT
We don't automatically copy the root image off the install source into ram so that we save ram.  However if you pass the 'inst.upgrade' boot option we will copy it off.

Note You need to log in before you can comment on or make changes to this bug.