Bug 804307 - Cannot leave full-screen when mouse is grabbed in server mode mouse
Cannot leave full-screen when mouse is grabbed in server mode mouse
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On: 801620
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-17 12:51 EDT by Marian Krcmarik
Modified: 2012-06-20 08:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:19:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Krcmarik 2012-03-17 12:51:53 EDT
Description of problem:
It's not possible to leave full-screen from server mouse mode (vdagent stopped/not running/not presented). Keyboard shortcut passed from User portal - Shift-F11 in default does not work and It's not possible to show the Menu which contains Leave fullscreen button. This was reported for spicy as well on Freedesktop - https://bugs.freedesktop.org/show_bug.cgi?id=40043 since There is no movement and It seems to me as ugly gap I am filing here as well.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-1.el6.x86_64
spice-gtk-0.11-1.el6.x86_64
spice-xpi-2.7-11.el6.x86_64
spice-protocol-0.10.1-1.el6.noarch
spice-glib-0.11-1.el6.x86_64
spice-gtk-tools-0.11-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Connect to a guest with remote-viewer spice client and switch to full-screen.
2. Be sure your mouse is grabbed inside guest with server mode mouse.
3. Try to get out of full-screen
  
Actual results:
No way

Expected results:
SHift-F11 should t least work

Additional info:
Comment 2 Marc-Andre Lureau 2012-03-18 08:58:01 EDT
What is your version of gtk?

It should be fixed with gtk2-2.18.9-10.el6

https://bugzilla.redhat.com/show_bug.cgi?id=801620
Comment 3 Marian Krcmarik 2012-03-18 09:09:26 EDT
(In reply to comment #2)
> What is your version of gtk?
> 
> It should be fixed with gtk2-2.18.9-10.el6
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=801620

$ rpm -q gtk2
gtk2-2.18.9-10.el6.x86_64

Shift+F11 works in client mouse mode, It does not work in server mouse mode, as well as It's not possible to unhide the upper menu.
Comment 4 Marc-Andre Lureau 2012-03-18 12:31:58 EDT
(In reply to comment #3)
> well as It's not possible to unhide the upper menu.

You'll have to first release the server mouse to unhide it.
Comment 5 Marc-Andre Lureau 2012-03-18 13:45:43 EDT
Proposed patch to solve keybindings issue in server mode mouse sent to spice mailing list.
Comment 9 Marc-Andre Lureau 2012-04-20 09:23:15 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 11 errata-xmlrpc 2012-06-20 08:19:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0767.html

Note You need to log in before you can comment on or make changes to this bug.