Bug 804331 - FTBFS:error: 'LLVMInitializePowerPCAsmParser' was not declared in this scope
FTBFS:error: 'LLVMInitializePowerPCAsmParser' was not declared in this scope
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: ldc (Show other bugs)
17
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: MERCIER Jonathan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-17 16:56 EDT by Karsten Hopp
Modified: 2012-03-18 20:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-18 20:26:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2012-03-17 16:56:59 EDT
Description of problem:
build aborts on PPC:

/builddir/build/BUILD/ldc-201210207git72d510c/gen/main.cpp:468:1: error: 'LLVMInitializePowerPCAsmParser' was not declared in this scope

Version-Release number of selected component (if applicable):
ldc-2-11.201210207git72d510c.fc17

How reproducible:
always

Steps to Reproduce:
1.ppc-koji build --scratch f17 ldc-2-11.201210207git72d510c.fc17.scr.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=447603

Expected results:


Additional info:
Comment 1 MERCIER Jonathan 2012-03-18 20:26:21 EDT
i have talk to upstream and it seem is not really a ldc bug, but more a llvm problam because they are cuirrently no PPC ASM parser in LLVM.
Comment 2 MERCIER Jonathan 2012-03-18 20:27:03 EDT
i have talk to upstream and it seem is not really a ldc bug, but more a llvm problam because they are cuirrently no PPC ASM parser in LLVM.

I close this issue feel free to open it again if they are any news

Note You need to log in before you can comment on or make changes to this bug.