Bug 804335 - FTBFS: ./calcnewt: error while loading shared libraries: /lib64/libjack.so.0: R_PPC64_ADDR32 fff8631f498 for symbol `' out of range
FTBFS: ./calcnewt: error while loading shared libraries: /lib64/libjack.so.0:...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: timidity++ (Show other bugs)
17
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-17 17:22 EDT by Karsten Hopp
Modified: 2013-01-20 11:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-20 11:16:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2012-03-17 17:22:53 EDT
Description of problem:
builds on PPC64 abort with this error, PPC32 builds fine:
gcc  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -DCONFIG_FILE1=\"/etc/timidity++.cfg\" -DCONFIG_FILE2=\"/etc/timidity.cfg\" -pthread  -Wl,-z,relro -o calcnewt calcnewt.o  -lasound -lm -ldl -lpthread -lm -ldl -lpthread -lm -ldl -lpthread -L/usr/lib -lao -L/usr/lib -lFLAC -lm -lncurses -ldl      -ljack   -L/usr/lib -lvorbis -lm -lvorbisenc -L/usr/lib -logg -lspeex -logg
./calcnewt > newton_table.c
./calcnewt: error while loading shared libraries: /lib64/libjack.so.0: R_PPC64_ADDR32 fff8631f498 for symbol `' out of range
make[2]: *** [newton_table.c] Error 127

Version-Release number of selected component (if applicable):
timidity++-2.13.2-29.cvs20111110.fc17

How reproducible:
always

Steps to Reproduce:
1.ppc-koji build --scratch --arch-override=ppc64 timidity++-2.13.2-29.cvs20111110.fc17.scr.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=447646

Expected results:


Additional info:
seems to be an old problem, the last version that build on PPC64 was timidity++-2.13.2-23.fc15 -> http://ppc.koji.fedoraproject.org/koji/packageinfo?packageID=8211
Comment 1 Phil Knirsch 2013-01-20 11:16:19 EST
We have a f17 update that builds fine on ppc64, so closing this bug as ERRATA.

Thanks & regards, Phil

Note You need to log in before you can comment on or make changes to this bug.