Bug 804381 - paint flashing after updating to firefox 11
paint flashing after updating to firefox 11
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
16
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-18 09:36 EDT by Peter Backes
Modified: 2012-03-28 11:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-28 11:41:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Backes 2012-03-18 09:36:48 EDT
Description of problem:
After updating to firefox 11, it started to tint everyting in funny colors. I noticed in about:config that nglayout.debug.paint_flashing was set to true. So the cause is apparently this debug feature called paint flashing.

This must have been caused either by

- nglayout.debug.paint_flashing being set to true all the time in my configuration for whatever reason, yet never having an effect. perhaps  previous firefox packages before 11.0-1.fc16 were not debug-enabled builds? Is the firefox 11 fedora package supposed to be a debug-enabled build?

- or nglayout.debug.paint_flashing must have been enabled for some reason by the update....

Version-Release number of selected component (if applicable):
firefox-11.0-1.fc16.i686

How reproducible:
once

Steps to Reproduce:
1. yum update
2. start firefox

Actual results:
paint flashing

Expected results:
no paint flashing

Additional info:
setting nglayout.debug.paint_flashing to false fixes the problem
Comment 1 Jan Horak 2012-03-27 09:38:59 EDT
We don't ship debug enabled packages. I don't have option 'nglayout.debug.paint_flashing' present in about:config at all. It may come with some addon you have installed. Try 'firefox -ProfileManager', create new profile and check the mentioned option.
Comment 2 Peter Backes 2012-03-27 13:15:40 EDT
(In reply to comment #1)
> We don't ship debug enabled packages.

But then why can the setting have any effect if the packages are not debug enabled? http://kb.mozillazine.org/About:config_entries describes the effect of this setting as "In debug-enabled builds, flash painted elements/objects when Caps Lock is on" (btw, contrary to this statement, Caps Lock is not required to be on)

> I don't have option
> 'nglayout.debug.paint_flashing' present in about:config at all.

Press the right mouse button in about:config and choose new => boolean to create it with true as its value. Perhaps this is related to mozilla bz https://bugzilla.mozilla.org/show_bug.cgi?id=334411

> It may come
> with some addon you have installed. Try 'firefox -ProfileManager', create new
> profile and check the mentioned option.

As I already described, the setting may have been there for whatever reason before I updated to firefox 11, or it may for some reason have been created by the update. This is a pretty old profile that has seen many versions of Firefox/Seamonkey/Navigator. But the setting never had any effect. I can set it to false or remove it to get rid of the effect; the question is why does it suddenly have some effect after updating to firefox 11.
Comment 3 Jan Horak 2012-03-28 11:41:01 EDT
No idea. You may check mozilla hg repo for latest changes. The page http://kb.mozillazine.org/About:config_entries might be outdated.
See:
http://mxr.mozilla.org/mozilla-central/search?string=nglayout.debug.paint_flashing
for nglayout.debug.paint_flashing usage.

As you referred https://bugzilla.mozilla.org/show_bug.cgi?id=334411 this is most likely the reason, because this change has been introduced in Firefox 11.

Closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.